qq_55901971 2022-04-26 12:58 采纳率: 100%
浏览 351
已结题

Kali安装pytic时未满足依赖

下列软件包有未满足的依赖关系:
libpython2.7-minimal : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
libpython2.7-stdlib : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
python : 依赖: python-minimal (= 2.7.5-5ubuntu3) 但无法安装它
依赖: libpython-stdlib (= 2.7.5-5ubuntu3) 但无法安装它
python-support : 依赖: python-minimal 但无法安装它
python2 : 破坏: python (< 2.7.15-2) 但是 2.7.5-5ubuntu3 正要被安装
python2.7 : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
python2.7-minimal : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
python3-six : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
python3-yaml : 破坏: python (< 2.7.18) 但是 2.7.5-5ubuntu3 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

  • 写回答

3条回答 默认 最新

  • 不会长胖的斜杠 后端领域新星创作者 2022-04-26 14:21
    关注

    换个源试试
    更换一个源后(我更换的是sohu的源,之前是网易的源),再次sudo apt-get -f install。搞定这些依赖问题。之后再sudo dpkg -i 文件名.deb 软件成功安装。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(2条)

报告相同问题?

问题事件

  • 系统已结题 5月4日
  • 已采纳回答 4月26日
  • 赞助了问题酬金10元 4月26日
  • 创建了问题 4月26日

悬赏问题

  • ¥50 wordpress项目注册报失败刷新后其实是成功状态,请求排查原因
  • ¥20 linxu服务器僵尸进程不释放,代码如何修改?
  • ¥15 pycharm激活不成功
  • ¥40 如果update 一个列名为参数的value
  • ¥15 基于51单片机的水位检测系统设计中LCD1602一直不显示
  • ¥15 OCS2安装出现问题,请大家给点意见
  • ¥15 ros小车启动launch文件报错
  • ¥15 vs2015到期想登陆但是登陆不上
  • ¥15 IPQ5018制作烧录固件,boot运行失败(操作系统-linux)(相关搜索:操作系统)(相关搜索:操作系统)
  • ¥20 icefall在librispeech基础上加入个人数据集