AsiaDIT 2022-05-04 18:12 采纳率: 42.9%
浏览 3951
已结题

Error [ERR_REQUIRE_ESM]: Must use import to load ES Module

问题遇到的现象和发生背景

nodejs的版本是12.17.0 在练习一个自定义cli的过程中,遇到了以下问题:
安装的依赖有如下:
"dependencies": {
"chalk": "^5.0.1",
"clear": "^0.1.0",
"commander": "^9.2.0",
"download-git-repo": "^3.0.2",
"figlet": "^1.5.2",
"handlebars": "^4.7.7",
"open": "^8.4.0",
"ora": "^6.1.0"
}

问题相关

PS E:\node-proj\vue-auto-router-cli> kkb init test
internal/modules/cjs/loader.js:1154
throw new ERR_REQUIRE_ESM(filename, parentPath, packageJsonPath);
^

Error [ERR_REQUIRE_ESM]: Must use import to load ES Module: E:\node-proj\vue-auto-router-cli\node_modules\chalk\source\index.js
require() of ES modules is not supported.
require() of E:\node-proj\vue-auto-router-cli\node_modules\chalk\source\index.js from E:\node-proj\vue-auto-router-cli\lib\init.js is an ES module file as it is a .js file whose nearest parent package.json contains "type": "module" which defines all .js files in that package scope as ES modules.
Instead rename index.js to end in .cjs, change the requiring code to use import(), or remove "type": "module" from E:\node-proj\vue-auto-router-cli\node_modules\chalk\package.json.

at Object.Module._extensions..js (internal/modules/cjs/loader.js:1154:13)
at Module.load (internal/modules/cjs/loader.js:986:32)
at Function.Module._load (internal/modules/cjs/loader.js:879:14)
at Module.require (internal/modules/cjs/loader.js:1026:19)
at require (internal/modules/cjs/helpers.js:72:18)
at Object.<anonymous> (E:\node-proj\vue-auto-router-cli\lib\init.js:4:15)
at Module._compile (internal/modules/cjs/loader.js:1138:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1158:10)
at Module.load (internal/modules/cjs/loader.js:986:32)
at Function.Module._load (internal/modules/cjs/loader.js:879:14) {

code: 'ERR_REQUIRE_ESM'
}
PS E:\node-proj\vue-auto-router-cli>

运行结果及报错内容

网上能搜到的方法都用了 统统没用 欢迎有经验的玩家支招

  • 写回答

5条回答 默认 最新

  • hyh123a 全栈领域新星创作者 2022-05-04 18:42
    关注

    可能是nodejs版本过低导致的,尝试下这两个版本两个版本来进行安装:v14和v16(n为node包版本管理工具)

    • ndoe 14版本尝试
      sudo npm install -g n
      sudo n 14 # 切换到14版本
      node-v
      sudo npm i
      
    • node16版本尝试
      sudo n 16 # 切换到16版本
      node-v
      sudo npm i
      
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(4条)

报告相同问题?

问题事件

  • 系统已结题 5月16日
  • 已采纳回答 5月8日
  • 创建了问题 5月4日

悬赏问题

  • ¥15 需要数据库运行的图片
  • ¥15 如何获取vue-video-editor?
  • ¥100 vs2019 mfc程序如何实现64*64/48*48大小的真彩色工具栏
  • ¥15 全志v3s耳机音频输出口怎么外接功放
  • ¥15 华为ensp使用基本ACL限制公司网络访问
  • ¥15 帮我做下照片上的PLC题
  • ¥15 labview2022 使用modbus报缺少依赖?
  • ¥15 谷歌地图是不是不开通结算功能,api会使用不了哦
  • ¥15 unity腾讯云对象存储机型适配
  • ¥15 求全国交通咨询模拟代码,要求如下,可以完全在dev c++运行