ArtemisC
KillerWhaleL
采纳率100%
2019-07-30 01:26

在daemon.json中配置私服仓库地址,但是push本地镜像至私有仓库的时候还是提示http的问题!!!

已采纳

图片说明

配置和操作如图所示:

1.修改了配置文件之后重启服务

2.ip地址和端口没有问题

3.push镜像就提示http的问题。

求大神解答,谢谢。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • weixin_42686388 嫒de洫天使 2年前

    我之前是用docker harbor搭建私服的时候,碰到过一样的问题
    首先确认私服的环境配置的是http的:
    harbor.cfg : ui-url-protocol=http
    修改配置文件端口映射
    docker-compose.yml:
    registry:ports: 5000:5000
    proxy: ports: 8080:80 8443:443
    common/templates/registry/config.yml: auth:realm:url:port
    若harbour只启用了HTTP,但是默认docker是使用https进行通信的, 需要做如下配置:

    vim     /etc/docker/daemon.json
    
            {
                "exec-opts": ["native.cgroupdriver=systemd"],
                "log-driver": "json-file",
                "insecure-registries": ["127.0.0.1:5000"],   //配置的端口,必须跟harbor服务的端口一致
                "log-opts": {
                  "max-size": "10m"
                }
            }
    
    点赞 评论 复制链接分享
  • zqbnqsdsmd zqbnqsdsmd 2年前