weixin_43521650
张荧
采纳率0%
2019-07-30 10:41 浏览 1.0k

eclipse下载后打不开,提示查看log文件

!SESSION 2019-07-29 12:10:42.472 -----------------------------------------------
eclipse.buildId=4.4.2.M20150204-1700
java.version=12.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=zh_CN
Framework arguments: -product org.eclipse.epp.package.standard.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.standard.product

!ENTRY org.eclipse.oomph.setup.editor 4 0 2019-07-29 12:10:46.386
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.oomph.setup.editor [215]
Unresolved requirement: Require-Bundle: org.eclipse.oomph.setup.ui; bundle-version="[1.14.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.oomph.setup.ui; bundle-version="1.14.0.v20190704-1252"; singleton:="true"
org.eclipse.oomph.setup.ui [219]
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.ui; bundle-version="[1.0.2,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.oauth; bundle-version="[1.0.0,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.nebula.widgets.tablecombo; bundle-version="[1.0.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.nebula.widgets.tablecombo; bundle-version="1.2.0.201907151344"
org.eclipse.nebula.widgets.tablecombo [194]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.oomph.setup.ui 4 0 2019-07-29 12:10:46.386
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.oomph.setup.ui [219]
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.ui; bundle-version="[1.0.2,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.oauth; bundle-version="[1.0.0,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.nebula.widgets.tablecombo; bundle-version="[1.0.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.nebula.widgets.tablecombo; bundle-version="1.2.0.201907151344"
org.eclipse.nebula.widgets.tablecombo [194]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.oomph.setup.ui.questionnaire 4 0 2019-07-29 12:10:46.386
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.oomph.setup.ui.questionnaire [220]
Unresolved requirement: Require-Bundle: org.eclipse.oomph.setup.ui; bundle-version="[1.10.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.oomph.setup.ui; bundle-version="1.14.0.v20190704-1252"; singleton:="true"
org.eclipse.oomph.setup.ui [219]
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.ui; bundle-version="[1.0.2,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.userstorage.oauth; bundle-version="[1.0.0,2.0.0)"; x-installation:="greedy"; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.nebula.widgets.tablecombo; bundle-version="[1.0.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.nebula.widgets.tablecombo; bundle-version="1.2.0.201907151344"
org.eclipse.nebula.widgets.tablecombo [194]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


上面是log文件的内容
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答 默认 最新

  • qq_39019765 打杂的程序员 2019-07-30 10:43
  • yyjjttww yyjjttww 2019-07-30 11:00

    查看下载的eclipse和你本机的jdk是否匹配。
    如果不匹配需要安装指定版本的jdk,然后在eclipse.ini里指定。

    https://blog.csdn.net/qq_15784927/article/details/79033847

    点赞 评论 复制链接分享
  • chenyanfeng2011 你若安好便是晴天 2019-07-30 11:24

    先安装好jdk,然后再安装eclipse

    点赞 评论 复制链接分享
  • Demo_Null Demo_Null 2019-07-30 17:46

    环境没装没配,或者版本不一致,比如 火星 就不能用 1.6

    点赞 评论 复制链接分享

相关推荐