问题遇到的现象和发生背景
输入样例:
123 4577973
输出样例:
12:42:59
问题相关代码,请勿粘贴截图
#include<iostream>
using namespace std;
int main()
{
int c1, c2;
cin >> c1 >> c2;
int delta = c2 - c1;
int temp = (int)(delta * 1.0 / 100 + 0.5);
scanf("%02d:", temp / 3600);
temp %= 3600;
scanf("%02d:", temp / 60);
temp %= 60;
scanf("%02d", temp);
return 0;
}