法学僧转行程序猿
2022-05-28 13:17
采纳率: 60%
浏览 220

如何解决requests依赖urllib3<1.24,>=1.21.1而selenium 4.1.3又依赖urllib3 1.26的冲突?

如何解决requests需要urllib3<1.24,>=1.21.1,而selenium 4.1.3又需要urllib3 1.26的冲突?

具体如下:
我使用python3.7.8版本,安装了requests 2.19.1(这个时候我的urllib3是1.23版本)

但是,有些网站又要验证SLL,否则报错ssl.SSLError: [SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1091),我通过pip check查到原因是selenium 4.1.3 has requirement urllib3[secure,socks]~=1.26, but you have urllib3 1.23.

于是我将urllib3 1.23卸载安装成urllib3 1.26,这时候SLL验证不报错了,结果pip check又警告requests 2.19.1 has requirement urllib3<1.24,>=1.21.1, but you have urllib3 1.26.9. 这个警告导致我每次resquests请求都会弹出以下内容
D:\python\lib\site-packages\requests_init_.py:91: RequestsDependencyWarning: urllib3 (1.26.9) or chardet (3.0.4) doesn't match a supported version!
RequestsDependencyWarning)
有什么办法能够同时解决requests依赖urllib3<1.24,>=1.21.1而selenium 4.1.3又依赖urllib3 1.26的冲突?

1条回答 默认 最新

相关推荐 更多相似问题