m0_70575681 2022-06-19 14:16 采纳率: 100%
浏览 26
已结题

Android4.4使用okhttp报错 Expected Android API level 21+ but was 17

Android4.4使用okhttp报错 Expected Android API level 21+ but was 17。是不支持了吗?

  • 写回答

1条回答 默认 最新

  • 三杯五岳 2022-06-19 14:28
    关注

    作为安卓app开发平台使用最为广泛的网络框架okhttp,从okhttp3.13版本起,就要求android最低版本必须为android5.0(21),而对于依然使用比较广泛的低版本2.3+,则需要停留在3.12.x版本。
    可参考如下修改,亲测有效:https://blog.csdn.net/u013164293/article/details/124496657

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 已结题 (查看结题原因) 6月22日
  • 已采纳回答 6月19日
  • 创建了问题 6月19日

悬赏问题

  • ¥15 tensorrt 推理 yolov8框出现错误
  • ¥15 用hc 05,做蓝牙控制小车 小车只能说初始遥控方向影响,后续不能更改
  • ¥15 51单片机怎么把每次输入键值保存到数组作为我的确认键的判断条件呢
  • ¥15 c语言字符串单词入门问题报错
  • ¥30 我现在是双非人工智能专业不知道要不要转到软件工程专业
  • ¥15 请问12脉波整流机组的外特性曲线具体是如何推导
  • ¥15 abaqus里的python算法
  • ¥100 如何在思科模拟器中进入CEF模式
  • ¥15 Simulink 仿真如何使用MATLAB function模块获取到仿真过程中某一仿真时刻输入到模块的函数的值?
  • ¥50 关于#微信小程序#的问题:微信小程序支持h5实现webrtc h264 h265低延迟传输渲染,能付费帮我们解决一下吗