lilili07
2022-06-21 16:31
采纳率: 73.5%
浏览 59

安装paddlex报错

安装paddlx 2.0.0rc3的时候报了错具体错误我贴出来

C:\Users\exile>pip install paddlex==2.0.0rc3  --use

Usage:
  pip install [options] <requirement specifier> [package-index-options] ...
  pip install [options] -r <requirements file> [package-index-options] ...
  pip install [options] [-e] <vcs project url> ...
  pip install [options] [-e] <local project path> ...
  pip install [options] <archive url/path> ...

ambiguous option: --use (--use-deprecated, --use-feature, --use-pep517, --user?)

C:\Users\exile>pip install paddlex==2.0.0rc3  --user
WARNING: Ignoring invalid distribution -addlepaddle-gpu (c:\users\exile\anaconda3\lib\site-packages)
WARNING: Ignoring invalid distribution -addlepaddle-gpu (c:\users\exile\anaconda3\lib\site-packages)
Collecting paddlex==2.0.0rc3
  Using cached paddlex-2.0.0rc3-py3-none-any.whl (831 kB)
Collecting shapely>=1.7.0
  Using cached Shapely-1.8.2-cp37-cp37m-win_amd64.whl (1.3 MB)
Collecting scikit-learn==0.23.2
  Using cached scikit_learn-0.23.2-cp37-cp37m-win_amd64.whl (6.8 MB)
Requirement already satisfied: colorama in c:\users\exile\anaconda3\lib\site-packages (from paddlex==2.0.0rc3) (0.4.1)
Collecting visualdl>=2.1.1
  Using cached visualdl-2.2.3-py3-none-any.whl (2.7 MB)
Requirement already satisfied: tqdm in c:\users\exile\anaconda3\lib\site-packages (from paddlex==2.0.0rc3) (4.31.1)
Requirement already satisfied: scipy in c:\users\exile\anaconda3\lib\site-packages (from paddlex==2.0.0rc3) (1.2.1)
Collecting motmetrics
  Using cached motmetrics-1.2.5-py3-none-any.whl (161 kB)
Requirement already satisfied: opencv-python in c:\users\exile\anaconda3\lib\site-packages (from paddlex==2.0.0rc3) (4.5.5.64)
Requirement already satisfied: pyyaml in c:\users\exile\anaconda3\lib\site-packages (from paddlex==2.0.0rc3) (5.1)
Collecting lap
  Using cached lap-0.4.0.tar.gz (1.5 MB)
  Preparing metadata (setup.py) ... done
Collecting paddleslim==2.1.0
  Using cached paddleslim-2.1.0-py3-none-any.whl (300 kB)
Requirement already satisfied: pyzmq in c:\users\exile\anaconda3\lib\site-packages (from paddleslim==2.1.0->paddlex==2.0.0rc3) (18.0.0)
Requirement already satisfied: matplotlib in c:\users\exile\anaconda3\lib\site-packages (from paddleslim==2.1.0->paddlex==2.0.0rc3) (3.0.3)
Requirement already satisfied: pillow in c:\users\exile\anaconda3\lib\site-packages (from paddleslim==2.1.0->paddlex==2.0.0rc3) (5.4.1)
Collecting joblib>=0.11
  Using cached joblib-1.1.0-py2.py3-none-any.whl (306 kB)
Collecting threadpoolctl>=2.0.0
  Using cached threadpoolctl-3.1.0-py3-none-any.whl (14 kB)
Requirement already satisfied: numpy>=1.13.3 in c:\users\exile\anaconda3\lib\site-packages (from scikit-learn==0.23.2->paddlex==2.0.0rc3) (1.21.6)
Requirement already satisfied: requests in c:\users\exile\anaconda3\lib\site-packages (from visualdl>=2.1.1->paddlex==2.0.0rc3) (2.21.0)
Collecting flake8>=3.7.9
  Using cached flake8-4.0.1-py2.py3-none-any.whl (64 kB)
Collecting flask>=1.1.1
  Using cached Flask-2.1.2-py3-none-any.whl (95 kB)
Requirement already satisfied: pandas in c:\users\exile\anaconda3\lib\site-packages (from visualdl>=2.1.1->paddlex==2.0.0rc3) (0.24.2)
Collecting Flask-Babel>=1.0.0
  Using cached Flask_Babel-2.0.0-py3-none-any.whl (9.3 kB)
Collecting six>=1.14.0
  Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Requirement already satisfied: protobuf>=3.11.0 in c:\users\exile\anaconda3\lib\site-packages (from visualdl>=2.1.1->paddlex==2.0.0rc3) (3.19.4)
Collecting pre-commit
  Using cached pre_commit-2.19.0-py2.py3-none-any.whl (199 kB)
Collecting pillow
  Using cached Pillow-9.1.1-cp37-cp37m-win_amd64.whl (3.3 MB)
Collecting shellcheck-py
  Using cached shellcheck_py-0.8.0.4-py2.py3-none-win_amd64.whl (1.5 MB)
Collecting bce-python-sdk
  Using cached bce_python_sdk-0.8.73-py3-none-any.whl (204 kB)
Collecting xmltodict>=0.12.0
  Using cached xmltodict-0.13.0-py2.py3-none-any.whl (10.0 kB)
Requirement already satisfied: mccabe<0.7.0,>=0.6.0 in c:\users\exile\anaconda3\lib\site-packages (from flake8>=3.7.9->visualdl>=2.1.1->paddlex==2.0.0rc3) (0.6.1)
Collecting pyflakes<2.5.0,>=2.4.0
  Using cached pyflakes-2.4.0-py2.py3-none-any.whl (69 kB)
Collecting pycodestyle<2.9.0,>=2.8.0
  Using cached pycodestyle-2.8.0-py2.py3-none-any.whl (42 kB)
Collecting importlib-metadata<4.3
  Using cached importlib_metadata-4.2.0-py3-none-any.whl (16 kB)
Requirement already satisfied: Werkzeug>=2.0 in c:\users\exile\anaconda3\lib\site-packages (from flask>=1.1.1->visualdl>=2.1.1->paddlex==2.0.0rc3) (2.1.2)
Collecting itsdangerous>=2.0
  Using cached itsdangerous-2.1.2-py3-none-any.whl (15 kB)
Collecting click>=8.0
  Using cached click-8.1.3-py3-none-any.whl (96 kB)
Collecting Jinja2>=3.0
  Using cached Jinja2-3.1.2-py3-none-any.whl (133 kB)
Requirement already satisfied: Babel>=2.3 in c:\users\exile\anaconda3\lib\site-packages (from Flask-Babel>=1.0.0->visualdl>=2.1.1->paddlex==2.0.0rc3) (2.6.0)
Requirement already satisfied: pytz in c:\users\exile\anaconda3\lib\site-packages (from Flask-Babel>=1.0.0->visualdl>=2.1.1->paddlex==2.0.0rc3) (2018.9)
Requirement already satisfied: python-dateutil>=2.5.0 in c:\users\exile\anaconda3\lib\site-packages (from pandas->visualdl>=2.1.1->paddlex==2.0.0rc3) (2.8.0)
Requirement already satisfied: future>=0.6.0 in c:\users\exile\anaconda3\lib\site-packages (from bce-python-sdk->visualdl>=2.1.1->paddlex==2.0.0rc3) (0.17.1)
Collecting pycryptodome>=3.8.0
  Using cached pycryptodome-3.14.1-cp35-abi3-win_amd64.whl (1.8 MB)
Requirement already satisfied: cycler>=0.10 in c:\users\exile\anaconda3\lib\site-packages (from matplotlib->paddleslim==2.1.0->paddlex==2.0.0rc3) (0.10.0)
Requirement already satisfied: kiwisolver>=1.0.1 in c:\users\exile\anaconda3\lib\site-packages (from matplotlib->paddleslim==2.1.0->paddlex==2.0.0rc3) (1.0.1)
Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in c:\users\exile\anaconda3\lib\site-packages (from matplotlib->paddleslim==2.1.0->paddlex==2.0.0rc3) (2.3.1)
Collecting toml
  Using cached toml-0.10.2-py2.py3-none-any.whl (16 kB)
Collecting cfgv>=2.0.0
  Using cached cfgv-3.3.1-py2.py3-none-any.whl (7.3 kB)
Collecting virtualenv>=20.0.8
  Using cached virtualenv-20.14.1-py2.py3-none-any.whl (8.8 MB)
Requirement already satisfied: nodeenv>=0.11.1 in c:\users\exile\anaconda3\lib\site-packages (from pre-commit->visualdl>=2.1.1->paddlex==2.0.0rc3) (1.6.0)
Collecting identify>=1.0.0
  Using cached identify-2.5.1-py2.py3-none-any.whl (98 kB)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in c:\users\exile\anaconda3\lib\site-packages (from requests->visualdl>=2.1.1->paddlex==2.0.0rc3) (1.24.1)
Requirement already satisfied: idna<2.9,>=2.5 in c:\users\exile\anaconda3\lib\site-packages (from requests->visualdl>=2.1.1->paddlex==2.0.0rc3) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\exile\anaconda3\lib\site-packages (from requests->visualdl>=2.1.1->paddlex==2.0.0rc3) (2019.3.9)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\exile\anaconda3\lib\site-packages (from requests->visualdl>=2.1.1->paddlex==2.0.0rc3) (3.0.4)
Requirement already satisfied: zipp>=0.5 in c:\users\exile\anaconda3\lib\site-packages (from importlib-metadata<4.3->flake8>=3.7.9->visualdl>=2.1.1->paddlex==2.0.0rc3) (3.8.0)
Requirement already satisfied: typing-extensions>=3.6.4 in c:\users\exile\anaconda3\lib\site-packages (from importlib-metadata<4.3->flake8>=3.7.9->visualdl>=2.1.1->paddlex==2.0.0rc3) (4.2.0)
Collecting MarkupSafe>=2.0
  Using cached MarkupSafe-2.1.1-cp37-cp37m-win_amd64.whl (17 kB)
Requirement already satisfied: setuptools in c:\users\exile\anaconda3\lib\site-packages (from kiwisolver>=1.0.1->matplotlib->paddleslim==2.1.0->paddlex==2.0.0rc3) (62.3.2)
Collecting platformdirs<3,>=2
  Using cached platformdirs-2.5.2-py3-none-any.whl (14 kB)
Collecting filelock<4,>=3.2
  Using cached filelock-3.7.1-py3-none-any.whl (10 kB)
Collecting distlib<1,>=0.3.1
  Using cached distlib-0.3.4-py2.py3-none-any.whl (461 kB)
Building wheels for collected packages: lap
  Building wheel for lap (setup.py) ... error
  error: subprocess-exited-with-error

  × python setup.py bdist_wheel did not run successfully.
  │ exit code: 1
  ╰─> [28 lines of output]
      Partial import of lap during the build process.
      Generating cython files
      running bdist_wheel
      running build
      running config_cc
      unifing config_cc, config, build_clib, build_ext, build commands --compiler options
      running config_fc
      unifing config_fc, config, build_clib, build_ext, build commands --fcompiler options
      running build_src
      build_src
      building extension "lap._lapjv" sources
      building data_files sources
      build_src: building npy-pkg config files
      C:\Users\exile\Anaconda3\lib\site-packages\setuptools\command\install.py:37: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
        setuptools.SetuptoolsDeprecationWarning,
      running build_py
      creating build
      creating build\lib.win-amd64-cpython-37
      creating build\lib.win-amd64-cpython-37\lap
      copying lap\lapmod.py -> build\lib.win-amd64-cpython-37\lap
      copying lap\__init__.py -> build\lib.win-amd64-cpython-37\lap
      running build_ext
      No module named 'numpy.distutils._msvccompiler' in numpy.distutils; trying from distutils
      customize MSVCCompiler
      customize MSVCCompiler using build_ext
      CCompilerOpt.cc_test_flags[1013] : testing flags (/O2)
      error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
      CCompilerOpt.cache_flush[809] : write cache to path -> C:\Users\exile\AppData\Local\Temp\pip-install-dozfwroc\lap_fe98c73eb424418382a4a9c039ca38f4\build\temp.win-amd64-cpython-37\Release\ccompiler_opt_cache_ext.py
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for lap
  Running setup.py clean for lap
Failed to build lap
WARNING: Ignoring invalid distribution -addlepaddle-gpu (c:\users\exile\anaconda3\lib\site-packages)
Installing collected packages: lap, distlib, xmltodict, toml, threadpoolctl, six, shellcheck-py, shapely, pyflakes, pycryptodome, pycodestyle, platformdirs, pillow, MarkupSafe, joblib, itsdangerous, importlib-metadata, identify, filelock, cfgv, virtualenv, scikit-learn, Jinja2, flake8, click, bce-python-sdk, pre-commit, flask, paddleslim, motmetrics, Flask-Babel, visualdl, paddlex
  Running setup.py install for lap ... error
  error: subprocess-exited-with-error

  × Running setup.py install for lap did not run successfully.
  │ exit code: 1
  ╰─> [28 lines of output]
      Partial import of lap during the build process.
      Generating cython files
      running install
      C:\Users\exile\Anaconda3\lib\site-packages\setuptools\command\install.py:37: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
        setuptools.SetuptoolsDeprecationWarning,
      running build
      running config_cc
      unifing config_cc, config, build_clib, build_ext, build commands --compiler options
      running config_fc
      unifing config_fc, config, build_clib, build_ext, build commands --fcompiler options
      running build_src
      build_src
      building extension "lap._lapjv" sources
      building data_files sources
      build_src: building npy-pkg config files
      running build_py
      creating build
      creating build\lib.win-amd64-cpython-37
      creating build\lib.win-amd64-cpython-37\lap
      copying lap\lapmod.py -> build\lib.win-amd64-cpython-37\lap
      copying lap\__init__.py -> build\lib.win-amd64-cpython-37\lap
      running build_ext
      No module named 'numpy.distutils._msvccompiler' in numpy.distutils; trying from distutils
      customize MSVCCompiler
      customize MSVCCompiler using build_ext
      CCompilerOpt.cc_test_flags[1013] : testing flags (/O2)
      error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
      CCompilerOpt.cache_flush[809] : write cache to path -> C:\Users\exile\AppData\Local\Temp\pip-install-dozfwroc\lap_fe98c73eb424418382a4a9c039ca38f4\build\temp.win-amd64-cpython-37\Release\ccompiler_opt_cache_ext.py
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> lap

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure.

1条回答 默认 最新

相关推荐 更多相似问题