weixin_42707893
2019-08-26 16:55
采纳率: 81.8%
浏览 5.0k
已采纳

如何指定uwsgi在启动时默认的python版本

最近用django写了个项目,用的是python3.6,想放在服务器上用uwsgi+nginx运行的,因为服务器默认的是python2.7,所以我在服务器上安装了python3并创建软连接,这是我的uwsgi的配置文件,名字叫uwsgi.ini:
图片说明

我的项目在python2中运行不了,但是uwsgi启动时默认的是python2,所以我在配置文件中加了这样一句:plugin=python3 然后当我执行命令:uwsgi --ini uwsgi.ini时出现问题:

图片说明

我也知道问题在这里,
open(“./ python3_plugin.so”):没有这样的文件或目录[core / utils.c line 3724]
!无法加载uWSGI插件:./ python3_plugin.so:无法打开共享对象文件:没有这样的文件或目录!
但是我不知道创建这个文件之后我应该做什么?

恳请大佬解答。

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

2条回答 默认 最新

  • weixin_42707893 2019-08-26 18:53
    最佳回答

    已解决,之前有pip安装的uwsgi,进入安装文件一看是安装的有问题,之后的安装的教程见:https://blog.csdn.net/JENREY/article/details/86652539 安准之后重新建立一个软连接即可正常运行

    已采纳该答案
    评论
    解决 无用
    打赏 举报
查看更多回答(1条)

相关推荐 更多相似问题