犹大的誓言 2022-06-25 18:57 采纳率: 57.1%
浏览 1029
已结题

Elasticsearch新版客户端注入,jakarta/json/JsonException

最近项目中在使用Elasticsearch8.x版本,因此不用high level的客户端了,所以准备学习一下新的API。但是在配置client的时候,总是抛出jakarta/json/JsonException异常,但是我已经引入依赖了,还是解决不了。
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>org.example</groupId>
    <artifactId>es8.0</artifactId>
    <version>1.0-SNAPSHOT</version>

    <properties>
        <maven.compiler.source>8</maven.compiler.source>
        <maven.compiler.target>8</maven.compiler.target>
    </properties>
    <parent>
        <artifactId>spring-boot-starter-parent</artifactId>
        <groupId>org.springframework.boot</groupId>
        <version>2.4.5</version>
    </parent>

    <dependencies>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-test</artifactId>
        </dependency>
        <dependency>
            <groupId>co.elastic.clients</groupId>
            <artifactId>elasticsearch-java</artifactId>
            <version>8.2.2</version>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.core</groupId>
            <artifactId>jackson-databind</artifactId>
        </dependency>
        <dependency>
            <groupId>jakarta.json</groupId>
            <artifactId>jakarta.json-api</artifactId>
        </dependency>
    </dependencies>

</project>


img

img

img

  • 写回答

1条回答 默认 最新

  • 犹大的誓言 2022-06-26 11:55
    关注

    最后最后,经过我的不屑努力,通过翻译官方文档,发现了问题的所在。
    https://www.elastic.co/guide/en/elasticsearch/client/java-api-client/current/installation.html

    在官方的例子中,使用的依赖版本 elasticsearch-java 8.2.3,这个影响不大,主要的是jackson版本,例子中给的是jackson-databind 2.12.3,如果你单独使用这两个依赖编写程序,那么恭喜你,没有任何问题。
    但是,一旦你像我这样使用,引入了spring-boot-starter-parent做一个版本的控制,那么你就会出现官方例子中出现的问题,抛出ClassNotFoundException: jakarta.json.spi.JsonProvider。原因官方也说了,我贴一个图。

    img


    大家看一下我的maven配置

    <properties>
            <maven.compiler.source>8</maven.compiler.source>
            <maven.compiler.target>8</maven.compiler.target>
        </properties>
        <parent>
            <artifactId>spring-boot-starter-parent</artifactId>
            <groupId>org.springframework.boot</groupId>
            <version>2.7.0</version>
        </parent>
    
        <dependencies>
            <dependency>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-starter-web</artifactId>
            </dependency>
            <dependency>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-starter-test</artifactId>
            </dependency>
            <dependency>
                <groupId>co.elastic.clients</groupId>
                <artifactId>elasticsearch-java</artifactId>
                <version>8.2.3</version>
            </dependency>
    
            <dependency>
                <groupId>com.fasterxml.jackson.core</groupId>
                <artifactId>jackson-databind</artifactId>
            </dependency>
            <dependency>
                <groupId>jakarta.json</groupId>
                <artifactId>jakarta.json-api</artifactId>
                <version>2.0.1</version>
            </dependency>
            <dependency>
                <groupId>junit</groupId>
                <artifactId>junit</artifactId>
                <scope>test</scope>
            </dependency>
            <dependency>
                <groupId>org.projectlombok</groupId>
                <artifactId>lombok</artifactId>
            </dependency>
        </dependencies>
    
    

    用的是2.7.0这个版本,这个版本里面,jackson的两个依赖包版本都被控制了。如图

    img

    我们看一下版本是多少

    img

    img

    如上两个图,发现问题了。jakarta.json-api依赖使用的是1.x,但是这个版本官方也说明应为xxx改动,2.x和1.x不一样,所以这里我们设置正确版本即可。之后就可以愉快的开始新客户端API的学习了。
    有必要吐槽一下,Java High Level REST Client没用多久就又换了,现在用新版本的写不动API的话着实是在写屎山了。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论 编辑记录

报告相同问题?

问题事件

  • 系统已结题 7月4日
  • 已采纳回答 6月26日
  • 创建了问题 6月25日

悬赏问题

  • ¥15 python中aiohttp.client_exceptions.ContentTypeError
  • ¥30 DeepLung肺结节检测生成最大froc值对应的epoch报错
  • ¥15 信号发生器如何将频率调大,步尽值改成10
  • ¥15 keil 5 编程智能家具,风扇台灯开关,人体感应等
  • ¥100 找一名渗透方面的专家
  • ¥20 使用Matlab APP设计一个插补小程序
  • ¥15 evo评估时曲线出现问题
  • ¥15 eNSP拓扑图配置实验
  • ¥20 有没有兄弟会替换fmod studio的.bank文件内的音效?
  • ¥20 如何解决访问网址被屏蔽的情况