duan5801
2008-09-24 15:12 阅读 79
已采纳

在OS X上使用Aptana Studio和Xdebug或Zend调试器进行Php调试

Have you managed to get Aptana Studio debugging to work? I tried following this, but I don't see Windows -> Preferences -> Aptana -> Editors -> PHP -> PHP Interpreters in my menu (I have PHP plugin installed) and any attempt to set up the servers menu gives me "socket error" when I try to debug. Xdebug is installed, confirmed through php info.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

3条回答 默认 最新

  • 已采纳
    duanpanzhu2910 duanpanzhu2910 2008-09-25 06:29

    I've been using ZendDebugger with Eclipse (on OS X) for a while now and it works great!

    Here's the recipe that's worked well for me.

    1. install Eclipse PDT via "All in one" package at: http://www.zend.com/en/community/pdt
    2. install ZendDebugger.so (http://www.zend.com/en/community/pdt)
    3. configure your php.ini w/ the ZendDebugger extenssion (info below)

    Configuring ZendDebugger:

    1. edit php.ini
    2. add the following:

      [Zend]
      zend_extension=/full/path/to/ZendDebugger.so
      zend_debugger.allow_hosts=127.0.0.1
      zend_debugger.expose_remotely=always
      zend_debugger.connector_port=10013

    Now run "php -m" in the command line to output all the installed modules. If you see the following then its installed just fine

    [Zend Modules]  
    Zend Debugger
    

    Now restart Apache so that it reloads PHP w/ the ZendDebugger. Create a dummy page with in it and examine the output to make sure the PHP apache module picked up ZendDebugger as well. If it's setup right you will see something like the following text somewhere in phpinfo()'s output.

    with Zend Debugger v5.2.14, Copyright (c) 1999-2008, by Zend Technologies

    OK - but you wanted Aptana Studio... at this point I install the Aptana Studio Plugin into the PDT build of Eclipse. The instructions for that are at: http://www.aptana.com/docs/index.php/Plugging_Aptana_into_an_existing_Eclipse_configuration

    That setup has served me well for a while - hopefully it helps you too

    -Arin

    点赞 5 评论 复制链接分享
  • doulang6695 doulang6695 2008-09-24 17:43

    This is not related to Aptana Studio, but if you are looking for a PHP XDebug debugger client on OS X, you can try MacGDBp (Free/GPL).

    点赞 7 评论 复制链接分享
  • dongxun1142 dongxun1142 2013-02-08 14:53

    I realize that this is a old thread but I was having the same problem with Aptana Studio 3 and FireFox. If anyone is having this problem make sure that FireFox has FireBug V1.8.X installed, any other version might give you the same problem...

    Hope this helps

    点赞 评论 复制链接分享

相关推荐