蓝白杨 2022-07-06 23:55 采纳率: 77.8%
浏览 272
已结题

vue脚手架中用npm安装vue-router报错

vue脚手架中用npm安装vue-router报错,初步认定是npm版本问题,版本过高,但在之前安装同样的依赖不会报错,是什么原因,怎么解决

img

  • 写回答

2条回答 默认 最新

  • horizon_zpy 2022-07-07 07:19
    关注

    你安装的是vue2,最新的vue-router依赖于vue3,所以,请先安装vue3,再安装vue-router,或者指定vue2兼容的vue-router版本

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 7月15日
  • 已采纳回答 7月7日
  • 创建了问题 7月6日

悬赏问题

  • ¥30 频率分析法分析绘制奈奎斯特图、波特图
  • ¥15 弹出来一万个系统找不到指定的文件框框,怎么解决
  • ¥15 ADS生成的微带线为什么是蓝色空心的
  • ¥15 求一下解题思路,完全不懂
  • ¥15 tensorflow
  • ¥15 densenet网络结构中,特征以cat方式复用后是怎么进行误差回传的
  • ¥15 STM32G471芯片spi设置了8位,总是发送16位
  • ¥15 R语言并行计算beta-NTI中tree文件的类型
  • ¥15 如何解读marsbar导出的ROI数据?
  • ¥20 求友友协助弄一下基于STC89C52单片机的声光控制灯原理图