CakePHP - 从Mysql升级到MariaDB

我在CakePHP 2.4中有很少的网站,并且必须将其Mysql API升级到MariaDB API,我想知道CakePHP 2.4本地支持MariaDB? 或者我必须为PHP安装一些扩展,并稍微更改CakePHP,希望有人可以给我一些建议,谢谢。</ p>
</ div>

展开原文

原文

I have few website in CakePHP 2.4, and have to upgrade its Mysql API to MariaDB API, I am wondering if CakePHP 2.4 support MariaDB natively? Or I have to install some extension for PHP, and change CakePHP a little bit, hope someone can give me some advice, thanks.

1个回答



当我在谷歌上搜索时,我喜欢这个 - https://mariadb.com/kb/en/mariadb-vs-mysql-compatibility/ ,所以他们的驱动程序,API是相同的。</ p >

所有MySQL连接器(PHP,Perl,Python,Java,.NET,MyODBC,Ruby,MySQL C连接器等)都与MariaDB保持不变。
PHP5存在一些安装问题 应该知道(旧的PHP5客户端如何检查库兼容性的错误。)</ strong> </ p>
</ div>

展开原文

原文

As I was googling, and I fond this - https://mariadb.com/kb/en/mariadb-vs-mysql-compatibility/, so their driver, API is same.

All MySQL connectors (PHP, Perl, Python, Java, .NET, MyODBC, Ruby, MySQL C connector etc) work unchanged with MariaDB. There are some installation issues with PHP5 that you should be aware of (a bug in how the old PHP5 client checks library compatibility).

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐