xiaotanggao 2022-07-25 18:29 采纳率: 85.7%
浏览 46
已结题

Logstash安装报错

问题相关代码,请勿粘贴截图

[xzj@localhost logstash-7.8.0]$ sudo ./bin/logstash-plugin install logstash-codec-json_lines
2022-07-25T18:27:29.291+08:00 [main] WARN FilenoUtil : Native subprocess control requires open access to sun.nio.ch
Pass '--add-opens java.base/sun.nio.ch=org.jruby.dist' or '=org.jruby.core' to enable.
LoadError: load error: rubygems/security -- java.lang.reflect.InaccessibleObjectException: Unable to make field private java.security.Provider java.security.MessageDigest.provider accessible: module java.base does not "opens java.security" to unnamed module @1f53481b
  require at org/jruby/RubyKernel.java:974
  require at /usr/local/logstash/logstash-7.8.0/vendor/jruby/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54
   <main> at /usr/local/logstash/logstash-7.8.0/vendor/jruby/lib/ruby/stdlib/rubygems/package.rb:44
  require at org/jruby/RubyKernel.java:974
  require at /usr/local/logstash/logstash-7.8.0/vendor/jruby/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54
   <main> at /usr/local/logstash/logstash-7.8.0/lib/pluginmanager/util.rb:18
  require at org/jruby/RubyKernel.java:974
  require at /usr/local/logstash/logstash-7.8.0/vendor/jruby/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54
   <main> at /usr/local/logstash/logstash-7.8.0/lib/pluginmanager/main.rb:31

  • 写回答

1条回答 默认 最新

  • aabbabababaa 2022-07-26 11:28
    关注

    什么安全代码权限?

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 8月4日
  • 已采纳回答 7月27日
  • 创建了问题 7月25日

悬赏问题

  • ¥25 由IPR导致的DRIVER_POWER_STATE_FAILURE蓝屏
  • ¥50 有数据,怎么建立模型求影响全要素生产率的因素
  • ¥50 有数据,怎么用matlab求全要素生产率
  • ¥15 TI的insta-spin例程
  • ¥15 完成下列问题完成下列问题
  • ¥15 C#算法问题, 不知道怎么处理这个数据的转换
  • ¥15 YoloV5 第三方库的版本对照问题
  • ¥15 请完成下列相关问题!
  • ¥15 drone 推送镜像时候 purge: true 推送完毕后没有删除对应的镜像,手动拷贝到服务器执行结果正确在样才能让指令自动执行成功删除对应镜像,如何解决?
  • ¥15 求daily translation(DT)偏差订正方法的代码