2017-05-21 13:06


I'll try to be brief and to the point.

  1. I'm using Codeigniter 3.1.4. with HMVC
  2. Working perfectly on localhost with 'pconnect' = FALSE;
  3. Problem at live server through shared hosting.
  4. max_user_connections = 10. Set by the Hosting company.
  5. Also added mysql.allow_persistent = Off to php.ini file.
  6. Gives the error Message: mysqli::real_connect(): (42000/1203): User <user> already has more than 'max_user_connections' active connections Filename:mysqli/mysqli_driver.php Line Number: 201
  7. Line 201 is calling mysqli::real_connect within db_connect function of mysqli_driver
  8. CI's official statement is "...CodeIgniter intelligently takes care of closing your database connections".

With pconnect = FALSE; and CI's "intelligent" closing of database connections, I don't see what should be causing the problem.


  • Was previously loading database groups through $this->load->database('group', TRUE); in each model (only one such call per model).
  • Tried resolving above error through autoloading 'database' library and setting $this->db->db_select('dbName'); in respective controllers+models but it's not always selecting the correct database when controller+model is loaded.
  • Does anyone know how db->db_select() works?

Any ideas would be great help. Thanks.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答


  • dongwo7858 dongwo7858 4年前

    Check your database setting inside applications/config folder.

    Somewhere you had mentioned mysql and somewhere mysqli.

    Remember current version of CodeIgniter doesn't support mysql.

    Hope it helps

    点赞 评论 复制链接分享