有图有派 2022-09-20 18:17 采纳率: 65.8%
浏览 20
已结题

flask服务器部署

部署网站我使用的是CentOS 7.8 64位的操作系统,在pycharm中使用pip freeze > requirements.txt收集了项目依赖后到服务器上使用pip install -r requirements.txt,但是服务器曝出错误,提示如下:

img

有人说可以使用pip install --user -r requirements.txt来安装,但是问题依旧,请问该如何解决?谢谢!

  • 写回答

2条回答 默认 最新

  • honestman_ 2022-09-20 23:03
    关注

    打开requirements.txt看一下有特殊的路径模块吗。把它删除

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 10月5日
  • 已采纳回答 9月27日
  • 创建了问题 9月20日

悬赏问题

  • ¥15 ghpython这里总是报错而且rhino视图窗口内不显示怎么办
  • ¥15 布尔运算推导,请证明
  • ¥15 有没有人会打学生成绩管理系统呀
  • ¥15 在使用Fiddler和夜神模拟器抓包的时候一直出现443该怎么办啊QAQ搜了好几个笔记都没有解决
  • ¥15 3x7的二维数组A、B、C,A中的任意1个数组元素与B的任意1个数组元素、同时又与C的任意1个数组元素比较,把不同位置出现相同数的比较称为无意义,反之称为有意义,把有意义的比较打印输出。
  • ¥20 预测模型怎么处理原始数据(随机森林)
  • ¥20 请问discuz3.5如何实现插入ckplayer全能播放器功能呢?
  • ¥15 thingsboard代码编译出错误
  • ¥15 博途v18仿真报错怎么解决
  • ¥15 欧姆龙plc枕式包装机 ST编程