ds42774
2015-06-15 12:59
浏览 89
已采纳

php zeromq扩展:无法加载动态库php_zmq.dll

I have XAMPP with PHP Version 5.6.8. I want to install zeromq extension. Tried the following dlls from http://pecl.php.net/package/zmq/1.1.2/windows. Of course I have extension=php_zmq.dll in \xampp\php\php.ini

php_zmq-1.1.2-5.6-nts-vc11-x64
php_zmq-1.1.2-5.6-ts-vc11-x64

php_zmq-1.1.2-5.6-nts-vc11-x86
php_zmq-1.1.2-5.6-ts-vc11-x86

Getting the error

PHP Warning:  PHP Startup: Unable to load dynamic library 
'C:\xampp\php\ext\php_zmq.dll' - %1 is not a valid Win32 application.in 
Unknown on line 0

图片转代码服务由CSDN问答提供 功能建议

XAMPP PHP版本5.6.8 。 我想安装zeromq扩展。 来自 http:// pecl。的以下dll。 php.net/package/zmq/1.1.2/windows 。 当然我在 \ xampp \ php \ php.ini中有 extension = php_zmq.dll

 <代码> php_zmq-1.1.2-5.6-NTS-VC11-64 
php_zmq-1.1.2-5.6-TS-VC11-64 
 
php_zmq-1.1.2  -5.6-nts-vc11-x86 
php_zmq-1.1.2-5.6-ts-vc11-x86 
   
 
 

获取错误

  PHP警告:PHP启动:无法加载动态库
'C:\ xampp \ php \ ext \ php_zmq.dll' - %1不是有效的Win32 application.in 
Unknown在第0行\  n   
 
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • doupu3211 2015-06-15 18:21
    已采纳

    Here is the dll worked for php 5.6.3. Details are in readme file

    https://github.com/kirensiva/zmqPHPVersion5.6.3

    点赞 评论
  • dongyan9950 2017-01-13 12:49

    I finally got it working: Download the http://pecl.php.net/package/zmq/1.1.2/windows "5.6 Thread Safe (TS) x86" version.

    Copy the php_zmq.dll to php/ext directory

    Then copy the libzmq.dll to the xamp/ root directory

    RESTART apache.

    点赞 评论

相关推荐 更多相似问题