Zane_Hua 2022-10-26 13:53 采纳率: 100%
浏览 63
已结题

python+appium出现的can't set attribute

问题遇到的现象和发生背景

通过python连接appium时

用代码块功能插入代码,请勿粘贴截图
from appium import webdriver


desired_caps={
        "platformName": "Android",
        "platformVersion": "7.1.2",
        "deviceName": "HUAWEI",
        "appPackage": "com.qqeng.adult",
        "appActivity": "com.qqeng.online.core.BaseActivity"
        }

driver = webdriver.Remote("http://localhost:4723/wd/hub",desired_caps)

运行结果及报错内容
Traceback (most recent call last):
  File "D:\web\bigzahui\adb_Shell\com.qqeng.online\QQenglish.py", line 10, in <module>
    driver = webdriver.Remote("http://localhost:4723/wd/hub",desired_caps)
  File "D:\web\python\lib\site-packages\appium\webdriver\webdriver.py", line 268, in __init__
    AppiumConnection(command_executor, keep_alive=keep_alive), desired_capabilities, browser_profile, proxy
  File "D:\web\bigzahui\venv\lib\site-packages\selenium\webdriver\remote\webdriver.py", line 277, in __init__
    self.start_session(capabilities, browser_profile)
  File "D:\web\python\lib\site-packages\appium\webdriver\webdriver.py", line 361, in start_session
    self.capabilities = response.get('value')
AttributeError: can't set attribute

我的解答思路和尝试过的方法

我尝试过重新搭建环境,结果还是这样

我想要达到的结果

预期结果:无报错信息

  • 写回答

2条回答 默认 最新

  • Zane_Hua 2022-10-26 15:21
    关注

    我的版本是3.7.6的,python的版本是没有问题的,,出问题的是

    img


    版本太高,目前最高2.7可能是出于别的原因换成2.2.0就可以了

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论 编辑记录
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 11月3日
  • 已采纳回答 10月26日
  • 创建了问题 10月26日

悬赏问题

  • ¥15 BP神经网络控制倒立摆
  • ¥20 要这个数学建模编程的代码 并且能完整允许出来结果 完整的过程和数据的结果
  • ¥15 html5+css和javascript有人可以帮吗?图片要怎么插入代码里面啊
  • ¥30 Unity接入微信SDK 无法开启摄像头
  • ¥20 有偿 写代码 要用特定的软件anaconda 里的jvpyter 用python3写
  • ¥20 cad图纸,chx-3六轴码垛机器人
  • ¥15 移动摄像头专网需要解vlan
  • ¥20 access多表提取相同字段数据并合并
  • ¥20 基于MSP430f5529的MPU6050驱动,求出欧拉角
  • ¥20 Java-Oj-桌布的计算