a1803483451
稳如老狗yyy
2019-09-09 21:17
采纳率: 100%
浏览 592
已采纳

打开eclipse 选择workspace时出现了需要查看logs的问题?

今天装了下mysql改了下环境变量。打开了eclipse后发现eclipse找不到jre了,于是我把环境变量改了回来然后发现eclipse没有提示找不到jre,让我选择个workspace,第一次我将其选择了原来的workspace中,提示错误

修改完环境变量后测试了环境变量是没有问题的 jdk版本是11
图片说明
打开了log后提示如下

!SESSION 2019-09-09 20:03:26.681 -----------------------------------------------
eclipse.buildId=4.12.0.I20190605-1800
java.version=11.0.4
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=zh_CN
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

This is a continuation of log file E:\java workspace\.metadata\.bak_0.log
Created Time: 2019-09-09 20:03:57.979

!ENTRY org.eclipse.jst.ws.ui 2 0 2019-09-09 20:03:57.979
!MESSAGE Could not resolve module: org.eclipse.jst.ws.ui [567]
  Unresolved requirement: Require-Bundle: org.eclipse.wst.ws.explorer; bundle-version="[1.0.204,1.1.0)"
    -> Bundle-SymbolicName: org.eclipse.wst.ws.explorer; bundle-version="1.0.950.v201903050508"; singleton:="true"
       org.eclipse.wst.ws.explorer [876]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.http.jetty; bundle-version="[1.0.0,4.0.0)"
           -> Bundle-SymbolicName: org.eclipse.equinox.http.jetty; bundle-version="3.7.100.v20190516-1504"
              org.eclipse.equinox.http.jetty [344]
                Unresolved requirement: Import-Package: org.eclipse.jetty.server; version="[9.4.0,10.0.0)"
                  -> Export-Package: org.eclipse.jetty.server; bundle-symbolic-name="org.eclipse.jetty.server"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.net.ssl,javax.security.auth,javax.servlet,javax.servlet.http,org.eclipse.jetty.http,org.eclipse.jetty.io,org.eclipse.jetty.io.ssl,org.eclipse.jetty.server.handler,org.eclipse.jetty.server.session,org.eclipse.jetty.util,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.ssl,org.eclipse.jetty.util.thread"
                     org.eclipse.jetty.server [424]
                       Unresolved requirement: Import-Package: javax.naming
                Unresolved requirement: Import-Package: org.eclipse.jetty.http; version="[9.4.0,10.0.0)"
                  -> Export-Package: org.eclipse.jetty.http; bundle-symbolic-name="org.eclipse.jetty.http"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.io,org.eclipse.jetty.util,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"
                     org.eclipse.jetty.http [421]
                       Unresolved requirement: Import-Package: org.eclipse.jetty.util; version="[9.4.18,10.0.0)"
                         -> Export-Package: org.eclipse.jetty.util; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.thread"
                            org.eclipse.jetty.util [426]
                              Unresolved requirement: Import-Package: javax.naming
                       Unresolved requirement: Import-Package: org.eclipse.jetty.io; version="[9.4.18,10.0.0)"
                         -> Export-Package: org.eclipse.jetty.io; bundle-symbolic-name="org.eclipse.jetty.io"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.net.ssl,org.eclipse.jetty.util,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.thread"
                            org.eclipse.jetty.io [422]
                              Unresolved requirement: Import-Package: org.eclipse.jetty.util.annotation; version="[9.4.18,10.0.0)"
                                -> Export-Package: org.eclipse.jetty.util.annotation; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.18.v20190429"; version="9.4.18"
                              Unresolved requirement: Import-Package: org.eclipse.jetty.util; version="[9.4.18,10.0.0)"
                                -> Export-Package: org.eclipse.jetty.util; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.thread"
                Unresolved requirement: Import-Package: org.eclipse.jetty.server.handler; version="[9.4.0,10.0.0)"
                  -> Export-Package: org.eclipse.jetty.server.handler; bundle-symbolic-name="org.eclipse.jetty.server"; bundle-version="9.4.18.v20190429"; version="9.4.18"; uses:="javax.servlet,javax.servlet.descriptor,javax.servlet.http,org.eclipse.jetty.http,org.eclipse.jetty.io,org.eclipse.jetty.server,org.eclipse.jetty.util,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"



我之前使用eclipse 是se版本 前几天学习web部分 去下载了ee版本 当时选择workspace时没有出现此问题,今天发现问题后我卸载了eclipse,重新从之前的解压包中解压eclipse再次尝试,还是有同样的问题:在选择workspace时报错。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • a1803483451
    稳如老狗yyy 2019-09-10 00:10
    已采纳

    已经解决了 ,方法是更改当前的jdk 我将11改成了1.8再次尝试运行成功了。

    点赞 评论

相关推荐