douqiju2520
2016-11-21 14:10
浏览 62
已采纳

Prestashop 1.7模块目录数据未找到

So i installed PrestaShop 1.7 on my local (keep in mind my local works perfectly find) moved it over to live staging (had no database import or exporting errors or installation errors),but for some reason everything works but if i open the CMS logged in, and i click on the tab "Modules & Services" i get the following message with a "try again" call to action button underneath the message.

"Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache"

So i tried clearing cache, tried searching for answers , but found unsecured replies which i cant rely on.

Also in my "Modules & Services" when i click on the tab "Installed modules" i get an "RequestException in RequestException.php line 51" saying SSL CA bundle not found, so my modules is broken , i did see im not the only one with this problem but havent seen any fix on this?

Also could it be that on my Apache server the SSL is blocking this module? which means i would have to get access because at this moment i do not have access.

Also i tried this secured sulotion, tripple checked all my changes still got the same exact error message. (https://github.com/PrestaShop/PrestaShop/pull/6848/files)

图片转代码服务由CSDN问答提供 功能建议

所以我在我的本地安装了PrestaShop 1.7(请记住我的本地作品完美找到)将其移至现场演出 (没有数据库导入或导出错误或安装错误),但由于某种原因一切正常,但如果我打开CMS登录,然后单击“模块和服务”选项卡,我会收到以下消息“再次尝试 消息下方的“号召性用语”按钮。

“无法获取目录数据,请稍后再试。原因:来自PrestaShop Addons的数据无效,无法在缓存中回退”< / strong>

所以我尝试清除缓存,尝试搜索答案,但找到了我无法依赖的无担保回复。

同样在我的“ 模块和服务“当我点击选项卡”已安装的模块“时,我收到”RequestException.php第51行中的RequestException“,说没有找到SSL CA包,所以我的模块坏了,我确实看到我不是唯一一个这样的 问题,但没有看到任何修复 这个?

也可能是在我的Apache服务器上SSL阻止了这个模块? 这意味着我必须访问,因为此时我无法访问。

此外,我尝试了这种安全的骚动,检查我所有的更改仍然得到了相同的确切错误消息。 ( https://github.com/PrestaShop/PrestaShop/pull/6848/files

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douxie7738 2016-12-12 11:54
    已采纳

    i have not tried this becuase i have moved back to version 1.6, but for anyone with the same problem, prestashop developer posted this to my question,just follow link.

    https://www.prestashop.com/forums/topic/569275-prestashop-17-modules-catalog-data-not-found/#entry2463881

    my solution was download the file https://curl.haxx.se/ca/cacert.pem and save into /app/cache/prod/. The problem exist because if the production cache is deleted then the file cacert.pem is deleted too.

    I check in https://github.com/P...pull/6848/files and in my offline copy that file classes/Tools.php have the constant declaration:

    const CACERT_LOCATION = 'https://curl.haxx.se/ca/cacert.pem';
    

    and that file must exist in:

    _PS_CACHE_DIR_.'cacert.pem'
    

    as you can see in this global definition:

    define('_PS_CACHE_CA_CERT_FILE_', _PS_CACHE_DIR_.'cacert.pem')
    

    so, I chek if the file cacert.pem exist in production cache and it was deleted...I hope this help. (ref, mrbrazzi)

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • dongnaota6386 2016-11-23 09:00

    I also had a similar problem and fixed it.

    I had the 'js' folder misplaced (for some unknown reason) and incomplete, so I downloaded the 'js' and 'themes' original folders form https://github.com/prestashop/prestashop and replaced them.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题