m0_67871155 2022-11-26 19:54 采纳率: 100%
浏览 90
已结题

eclipse连接MySQL数据库出错,加载驱动失败

eclipse连接mysql数据库,加载JDBC-MYSQL数据库驱动时出现问题。
使用的是MySQL5.7,下载的mysql-connector-java-5.1.40,我是一步一步的按照网上教程来的,但是加载驱动时出了问题,写了一串测试代码来测试驱动是否加载成功,但是一直报错,步骤很简单,应该是没有错的,但是加载驱动失败,测试代码一直报错,现在这种情况应该检查什么啊?(感觉是MySQL或者eclipse安装时出了问题,但是也找不到是什么问题)应该怎么修改啊?希望帮忙解答一下,谢谢了。
https://blog.csdn.net/cheng782326777/article/details/124800979?ops_request_misc=%257B%2522request%255Fid%2522%253A%2522166946367916782412566978%2522%252C%2522scm%2522%253A%252220140713.130102334.pc%255Fall.%2522%257D&request_id=166946367916782412566978&biz_id=0&utm_medium=distribute.pc_search_result.none-task-blog-2~all~first_rank_ecpm_v1~rank_v31_ecpm-14-124800979-null-null.142^v66^control,201^v3^control_2,213^v2^t3_control1&utm_term=eclipse%E8%BF%9E%E6%8E%A5mysql%E6%95%B0%E6%8D%AE%E5%BA%935.7&spm=1018.2226.3001.4187
我是采用的这种方法,但是失败了。

img

  • 写回答

2条回答 默认 最新

  • Huazie 全栈领域优质创作者 2022-11-26 20:27
    关注

    看你JDK 用的 18的, mysql连接还用 5.x,有点低了。
    解决方案:
    (1)JDK 换成 1.7, mysql还用这个5.x的, 加载驱动还用这个

    Class.forName("com.mysql.jdbc.Driver");
    

    (2)JDK 用 1.8以上的, mysql 驱动换成 8.x的, 加载驱动就用下面这个

    Class.forName("com.mysql.cj.jdbc.Driver");
    

    PS: 新版Eclipse的一个大坑
    项目创建时,如果勾选了 module-info.java,引外面的jar,需要这个在项目的 module-info.java 把 外面的jar 对应的模块 包含进来,类似如下:

    module Demo {
        requires java.desktop;
    }
    

    参考这篇:


    如有帮助,欢迎采纳哈!

    在这里插入图片描述

    本人的开源项目,欢迎star支持下!!!

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论 编辑记录
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 12月5日
  • 已采纳回答 11月27日
  • 修改了问题 11月26日
  • 创建了问题 11月26日

悬赏问题

  • ¥40 如果update 一个列名为参数的value
  • ¥15 基于51单片机的水位检测系统设计中LCD1602一直不显示
  • ¥15 OCS2安装出现问题,请大家给点意见
  • ¥15 ros小车启动launch文件报错
  • ¥15 vs2015到期想登陆但是登陆不上
  • ¥15 IPQ5018制作烧录固件,boot运行失败(操作系统-linux)(相关搜索:操作系统)(相关搜索:操作系统)
  • ¥20 icefall在librispeech基础上加入个人数据集
  • ¥30 keepalive高可用故障运维配置询问
  • ¥15 求帮助!国家电网内网u盘突然识别不出来了。
  • ¥15 matlab语音变速变调同时实现