FakeSmileJWX 2022-12-10 13:04 采纳率: 100%
浏览 24
已结题

Linux树莓派操作系统php7安装失败

我在树莓派上尝试搭建网站(个人博客)
然后我安装了nginx和php7
就在我安装php7的时候,它,报错了

 php7.0-common:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-curl:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
                     依赖: libcurl3:armhf (>= 7.18.0) 但是它将不会被安装
 php7.0-gd:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-json:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-mcrypt:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-opcache:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-readline:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它
 php7.0-xml:armhf : 依赖: php-common:armhf (>= 1:35) 但无法安装它

图片:

img

就上面这一坨
试过每个依赖单独安装,没用,aptitude也试过,也没用

  • 写回答

2条回答 默认 最新

  • 萌面超人me 2022-12-10 15:33
    关注

    您好!看到您遇到了在树莓派上安装 PHP 7 的问题。

    根据您提供的错误信息,问题可能是由于 PHP 的依赖关系导致的。由于您提供的错误信息缺少重要的细节,无法确定确切的原因。

    不过,您可以尝试以下方法来解决问题:

    1. 更新软件源:在命令行中输入以下命令,更新软件源:

    sudo apt update

    1. 尝试重新安装 PHP:如果上一步成功,您可以尝试再次安装 PHP:

    sudo apt install php7.0

    1. 清除软件缓存:如果上一步无法解决问题,您可以尝试清除软件缓存,然后再次安装 PHP:

    sudo apt clean
    sudo apt install php7.0

    如果以上方法都无法解决问题,您可以尝试提供更多细节信息,比如您安装 PHP 的命令、您使用的树莓派型号等,这样我们可以更好地帮助您解决问题。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 12月25日
  • 已采纳回答 12月17日
  • 创建了问题 12月10日

悬赏问题

  • ¥15 流式socket文件传输答疑
  • ¥20 keepalive配置业务服务双机单活的方法。业务服务一定是要双机单活的方式
  • ¥50 关于多次提交POST数据后,无法获取到POST数据参数的问题
  • ¥15 win10,这种情况怎么办
  • ¥15 如何在配置使用Prettier的VSCode中通过Better Align插件来对齐等式?(相关搜索:格式化)
  • ¥100 在连接内网VPN时,如何同时保持互联网连接
  • ¥15 MATLAB中使用parfor,矩阵Removal的有效索引在parfor循环中受限制
  • ¥20 Win 10 LTSC 1809版本如何无损提升到20H1版本
  • ¥50 win10 LTSC 虚拟键盘不弹出
  • ¥15 寻找能匹配的液晶显示屏。