bujuan__ 2022-12-20 15:34 采纳率: 61.9%
浏览 19
已结题

前端 vue packge-lock.json

问题遇到的现象和发生背景

一个内网项目已经成型的vue项目 想引入两个node_modules包 项目不可以联网 只能从通过u盘导入
放入项目启动不了报错应该是那块少了些配置

遇到的现象和发生背景,请写出第一个错误信息

我在联网的电脑上下载好了包 例如 mockjs 包 外网项目node_modules里只有mockjs的东西我全部复制
在packge.json 也写入了 mockjs
packge-lock.json 中内容太多没有找到. 这是一个问题 怎么能找到我需要的东西呢?

我的解答思路和尝试过的方法,不写自己思路的,回答率下降 60%

我尝试把我外网的项目放到内网电脑 发现外网可以正常启动的项目 放到内网电脑上也会报错 可能和webpack有关
我知道npm install 一下问题会全部解决 可是情况不允许 只能通过复制粘贴来搞定。。

  • 写回答

1条回答 默认 最新

  • 崽崽的谷雨 2022-12-20 18:01
    关注

    packge-lock.json 这个是锁定 版本的 。 只有 特定情况才会把 依赖 写道这里面 。也就是说 硬性某个依赖必须某个版本时才 在这里面写。
    如果 不必 ,那可以不写 到这个里面 。直接在 packge.json 里写 也行 。
    至于 太多找不到 只能 用搜索 编辑器 都带 全局搜索 。

    在package.json里面dependencies依赖包的版本号前面的符号有两种,一种是~,一种是^。

    的意思是匹配最近的小版本 比如1.0.2将会匹配所有的1.0.x版本,但不匹配1.1.0

    ^的意思是最近的一个大版本 比如1.0.2 将会匹配 所有 1.x.x, 但不包括2.x.x

    如果 想要 死版本 就不加 前缀 就行

    https://www.jb51.net/article/252560.htm

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 3月28日
  • 已采纳回答 3月20日
  • 创建了问题 12月20日

悬赏问题

  • ¥15 关于#sql#的问题:#情况描述 在用vs对项目进行调试时,出现找不到网络路径,然后查看SQL配置工具,发现SQL服务显示远程调用过程失败(相关搜索:防火墙)
  • ¥15 eNSP中基于默认路由及浮动路由的公司与分部互联和校园网综合项目
  • ¥15 主要进行描述泥浆在管路不同区段泥浆的密度不相同,泥浆的密度有高有低,此时管路的摩阻分布需要怎么计算,(标签-matlab)
  • ¥40 通过编制程序计算圆管内层流充分发展对流换热,参数如图5-4,以及公式5-16所示,要求用表5-6对程序计算准确性进行验证
  • ¥20 该学习哪个编程语言? AI会取代程序员吗?
  • ¥15 ensp如何拼通IP地址
  • ¥15 saber软件导入Ibis模型报错
  • ¥15 商城生产日期批次库存问题
  • ¥15 esp8266控制共阳极wrgb灯板无法关闭所有led灯
  • ¥100 python读取速度问题