IntelliJ IDEA中的PHP调试

好的,我可能很蠢但我无法让它起作用。</ p>

< p>设置为:</ p>


  • Ubuntu </ li>
  • apache2 </ li>
  • xdebug </ li>
    < li> IntelliJ IDEA 11.1.3 Ultimate </ li>
  • IntelliJ IDEA PHP插件</ li>
    </ ul>

    已安装xdebug。</ p>

    我想调试Drupal站点,在我的本地机器上,项目在这里:</ p>

      / var / www / luken / my-site 
    </ code > </ pre>

    和URL在这里:</ p>

      http:// localhost / luken / my-site 
    </ code> </ pre>

    因为我无法从现有源创建项目,所以我从头开始创建新项目(Web模块)。 现在的问题是,如果我正在运行“PHP脚本”的配置 - 调试器工作。 但是,如果我尝试使用PHP Web应用程序的配置(因此项目将在浏览器中打开),它无法连接到调试器。 我尝试了很多东西和不同的映射,但显然我错过了一些愚蠢的东西。 上面的设置应该如何配置?</ p>
    </ div>

展开原文

原文

Ok, I'm probably stupid but I cannot make it to work.

The setup is:

  • Ubuntu
  • apache2
  • xdebug
  • IntelliJ IDEA 11.1.3 Ultimate
  • IntelliJ IDEA PHP Plugin

xdebug is installed.

I would like to debug Drupal site, on my local machine, the project is here:

/var/www/luken/my-site

and URL is here:

http://localhost/luken/my-site

Because I couldn't create a project from existing sources, I created new project (web module) from scratch there. Now the thing is that if I'm running configuration for "PHP Script" - debugger works. But if I try to use configuration for PHP Web Application (so project would be opened in browser) it cannot connect to debugger. I tried a lot of things, and different mappings but obviously I'm missing something stupid. How configuration should look with above setup?

dongyoudi1342
dongyoudi1342 见blog.jetbrains.com/webide/2011/02/...验证php.ini中的xdebug.remote_enable=1。
接近 8 年之前 回复

2个回答



当然。 在发布问题后几分钟我找到了答案,无论之前的调查时间如何,但这里是:</ p>

我读了一些错误的信息,你不需要配置xdebug。 实际上,您需要修改/etc/php5/conf.d/xdebug.ini。 我在那里添加:</ p>

  xdebug.remote_enable = 1 
xdebug.remote_handler = dbgp
xdebug.remote_mode = req
xdebug.remote_host = 127.0.0.1
xdebug.remote_port = 9000 \ n </ code> </ pre>

我在关于配置Netbeans的文章中读到了这些内容。 确切地说:</ p>

  xdebug.remote_enable = 1 
</ code> </ pre>

^此行仅是必需的。</ p>

</ div>

展开原文

原文

Of course. I found answer few minutes after posting a question, regardless of hour of investigation before, but here it is:

I read somewhere wrong information that you doesn't need to configure xdebug. In reality, you need to modify /etc/php5/conf.d/xdebug.ini . I added there:

xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000

Which I read about in article about configuring Netbeans, and the thing worked. And precisely:

xdebug.remote_enable=1

^ This line is only required.



如果您正在使用PHP命令行界面(cli),则使用不同的php.ini。 因此,编辑 /etc/php/version/cli/php.ini </ code>,或明确指定php.ini,如</ p>

  php  -  S localhost:8080 -t“/ var / www / html / my_project”-c“/etc/php/7.0/apache2/php.ini"

</ div>

展开原文

原文

In case you're using PHPs command line interface (cli), a different php.ini is being used. Thus, either edit the /etc/php/version/cli/php.ini, or specify a php.ini explicitly, like

php -S localhost:8080 -t "/var/www/html/my_project" -c "/etc/php/7.0/apache2/php.ini"

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐