dongwei4444
2017-10-30 23:00
浏览 160
已采纳

管理员登录页面上的wordpress 403错误

I've got a problem here. I have a wordpress site and accidentally changed the http to https and I am not sure that I could change it back. What is sure that it loged me out and when I reload the admin login page it throws an error that my connection is not private and after that I got a 403 Forbidden page.

I have access to the FTP and tried to change the wp_config file, no success. Tried adding this: define('WP_HOME','http://example.com'); define('WP_SITEURL','http://example.com'); it only made the admin page reachable when I entered the user and pass it reloaded the login page.

I also tried to delete the .htaccess file, perhaps it is corrupted, but did not help.

Please help me with this issue.

图片转代码服务由CSDN问答提供 功能建议

我在这里遇到了问题。 我有一个wordpress网站并意外地将http更改为https而我是 不确定我是否可以改回来。 什么确定它让我失去了,当我重新加载管理员登录页面时,它会抛出一个错误,我的连接不是私密的,之后我得到了403 Forbidden页面。

我有权访问FTP并尝试更改wp_config文件,但没有成功。 尝试添加: define('WP_HOME','http://example.com'); define('WP_SITEURL','http://example.com'); it只在我输入用户时让管理页面可以访问并传递它重新加载登录页面。

我也试图删除.htaccess文件,也许它已损坏,但是 没有帮助。

请帮我解决这个问题。

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • drpkcwwav20524605 2017-10-31 08:34
    已采纳

    I managed to enter the admin page finally! So I added these two lines to wp_admin.php: define('WP_HOME','http://example.com'); define('WP_SITEURL','http://example.com'); afterward deleted the .htaccess file, then deleted browsing history, cleared cache and cookies. After all of this I could enter the admin page.

    Then I went to options/general and options/permalinks and saved the setting, it generated a .htaccess file and now it is working.

    I also tried removing the two added lines from wp_admin.php after all, but I broke the page so they are going to stay for a while.

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • douba3943 2017-10-30 23:09

    Look in your Wordpress database, there is a table called wp_options and an entry in option_name called 'siteurl' as the name suggests it holds the URL of your site. Change this back to http and you should be good. There is also an entry for home which will also have a URL for your site to be updated. Alternatively and also a better option, get a site certificate so that you can use https.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题