余skr 2023-03-31 15:04 采纳率: 92.3%
浏览 15
已结题

关于#c语言#的问题:语言括号匹配

一个括号匹配问题,不知道哪里错了,请指出
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

#include<bits/stdc++.h>
using namespace std;
char bi(char a,char b){
    if((a=='('&&b==')')||(a=='['&&b==']')||(a=='#'&&b=='#')) return '>';
    else if((a=='('&&b==']')||(a=='['&&b==')')) return '=';
    else if(a==')'||a==']') return '=';
    else if(a=='#'&&(b==')'||b==']')) return '=';
    else return '<';
}
int main(){
    stack<char>s;
    int n,i,m,j;
    scanf("%d",&n);
    getchar();
    for(i=0;i<n;i++){
        char a[10005]={0};
        gets(a);
        if(strcmp(a,"\n")==0){
            printf("YES\n");
        }else{
        char b='#';
        s.push(b);
        m=strlen(a);
        a[m]='#';
        for(j=0;j<=m;j++){
            if(bi(s.top(),a[j])=='<'){
                s.push(a[j]);
            }else if(bi(s.top(),a[j])=='>'){
                s.pop();
            }else if(bi(s.top(),a[j])=='='){
                printf("NO\n");
                break;
            }
        }
        if(s.empty()) printf("YES\n");
        else {
            for(;!s.empty();){
                s.pop();
            }
        }
}}
}

展开全部

  • 写回答

1条回答 默认 最新

  • threenewbee 2023-03-31 15:14
    关注

    括号匹配哪里需要那么麻烦
    很简单,定义一整数,开始为0
    遇到( +1
    遇到) -1,如果出现负数,或者遍历结尾不是0,就是不匹配,否则就是匹配。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
编辑
预览

报告相同问题?

问题事件

  • 系统已结题 4月8日
  • 已采纳回答 3月31日
  • 创建了问题 3月31日

悬赏问题

  • ¥15 KeiI中头文件找不到怎么解决
  • ¥15 QT6将音频采样数据转PCM
  • ¥15 本地安装org.Hs.eg.dby一直这样的图片报错如何解决?
  • ¥15 下面三个文件分别是OFDM波形的数据,我的思路公式和我写的成像算法代码,有没有人能帮我改一改,如何解决?
  • ¥15 Ubuntu打开gazebo模型调不出来,如何解决?
  • ¥100 有chang请一位会arm和dsp的朋友解读一个工程
  • ¥50 求代做一个阿里云百炼的小实验
  • ¥15 查询优化:A表100000行,B表2000 行,内存页大小只有20页,运行时3页,设计两个表等值连接的最简单的算法
  • ¥15 led数码显示控制(标签-流程图)
  • ¥20 为什么在复位后出现错误帧
手机看
程序员都在用的中文IT技术交流社区

程序员都在用的中文IT技术交流社区

专业的中文 IT 技术社区,与千万技术人共成长

专业的中文 IT 技术社区,与千万技术人共成长

关注【CSDN】视频号,行业资讯、技术分享精彩不断,直播好礼送不停!

关注【CSDN】视频号,行业资讯、技术分享精彩不断,直播好礼送不停!

客服 返回
顶部