余skr 2023-03-31 23:04 采纳率: 92.3%
浏览 14
已结题

关于#c语言#的问题:语言括号匹配

一个括号匹配问题,不知道哪里错了,请指出
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

#include<bits/stdc++.h>
using namespace std;
char bi(char a,char b){
    if((a=='('&&b==')')||(a=='['&&b==']')||(a=='#'&&b=='#')) return '>';
    else if((a=='('&&b==']')||(a=='['&&b==')')) return '=';
    else if(a==')'||a==']') return '=';
    else if(a=='#'&&(b==')'||b==']')) return '=';
    else return '<';
}
int main(){
    stack<char>s;
    int n,i,m,j;
    scanf("%d",&n);
    getchar();
    for(i=0;i<n;i++){
        char a[10005]={0};
        gets(a);
        if(strcmp(a,"\n")==0){
            printf("YES\n");
        }else{
        char b='#';
        s.push(b);
        m=strlen(a);
        a[m]='#';
        for(j=0;j<=m;j++){
            if(bi(s.top(),a[j])=='<'){
                s.push(a[j]);
            }else if(bi(s.top(),a[j])=='>'){
                s.pop();
            }else if(bi(s.top(),a[j])=='='){
                printf("NO\n");
                break;
            }
        }
        if(s.empty()) printf("YES\n");
        else {
            for(;!s.empty();){
                s.pop();
            }
        }
}}
}

  • 写回答

1条回答 默认 最新

  • threenewbee 2023-03-31 23:14
    关注

    括号匹配哪里需要那么麻烦
    很简单,定义一整数,开始为0
    遇到( +1
    遇到) -1,如果出现负数,或者遍历结尾不是0,就是不匹配,否则就是匹配。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 4月9日
  • 已采纳回答 4月1日
  • 创建了问题 3月31日

悬赏问题

  • ¥15 微信公众平台自制会员卡可以通过收款码收款码收款进行自动积分吗
  • ¥15 随身WiFi网络灯亮但是没有网络,如何解决?
  • ¥15 gdf格式的脑电数据如何处理matlab
  • ¥20 重新写的代码替换了之后运行hbuliderx就这样了
  • ¥100 监控抖音用户作品更新可以微信公众号提醒
  • ¥15 UE5 如何可以不渲染HDRIBackdrop背景
  • ¥70 2048小游戏毕设项目
  • ¥20 mysql架构,按照姓名分表
  • ¥15 MATLAB实现区间[a,b]上的Gauss-Legendre积分
  • ¥15 delphi webbrowser组件网页下拉菜单自动选择问题