一个括号匹配问题,不知道哪里错了,请指出
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes
#include<bits/stdc++.h>
using namespace std;
char bi(char a,char b){
if((a=='('&&b==')')||(a=='['&&b==']')||(a=='#'&&b=='#')) return '>';
else if((a=='('&&b==']')||(a=='['&&b==')')) return '=';
else if(a==')'||a==']') return '=';
else if(a=='#'&&(b==')'||b==']')) return '=';
else return '<';
}
int main(){
stack<char>s;
int n,i,m,j;
scanf("%d",&n);
getchar();
for(i=0;i<n;i++){
char a[10005]={0};
gets(a);
if(strcmp(a,"\n")==0){
printf("YES\n");
}else{
char b='#';
s.push(b);
m=strlen(a);
a[m]='#';
for(j=0;j<=m;j++){
if(bi(s.top(),a[j])=='<'){
s.push(a[j]);
}else if(bi(s.top(),a[j])=='>'){
s.pop();
}else if(bi(s.top(),a[j])=='='){
printf("NO\n");
break;
}
}
if(s.empty()) printf("YES\n");
else {
for(;!s.empty();){
s.pop();
}
}
}}
}