落落A 2023-04-11 11:19 采纳率: 63.6%
浏览 58
已结题

创建Vite 项目失败

创建Vite 项目失败,不知道缺少了啥,之前还是可以的,最近才不行的,具体报错如下显示

img

npx: installed 1 in 1.045s
internal/modules/run_main.js:54
    internalBinding('errors').triggerUncaughtException(
                              ^

Error [ERR_UNSUPPORTED_ESM_URL_SCHEME]: Only file and data URLs are supported by the default ESM loader
    at Loader.defaultResolve [as _resolve] (internal/modules/esm/resolve.js:666:11)
    at Loader.resolve (internal/modules/esm/loader.js:97:40)
    at Loader.getModuleJob (internal/modules/esm/loader.js:243:28)
    at ModuleWrap.<anonymous> (internal/modules/esm/module_job.js:42:40)
    at link (internal/modules/esm/module_job.js:41:36) {
  code: 'ERR_UNSUPPORTED_ESM_URL_SCHEME'
}

node 版本是v14.0.0
有遇到类似情况的小伙伴吗?请问你是怎么解决的?

  • 写回答

4条回答 默认 最新

  • 「已注销」 2023-04-11 22:48
    关注

    以下内容部分参考ChatGPT模型:


    你好,根据你提供的错误信息,看起来是缺少了某个模块。你可以尝试重新安装Vite和Vue.js,或者查看是否缺少了一些依赖。具体操作可以参考以下步骤:

    1. 确认安装了最新版本的Node.js和npm。

    2. 在终端中运行以下命令安装Vite:

      npm install vite -g

    3. 创建一个新的Vue.js项目:

      vue create my-project

    4. 进入项目目录并安装依赖:

      cd my-project
      npm install
      
    5. 启动项目:

      npm run dev

    如果以上步骤仍然不能解决问题,请提供更详细的错误信息以供进一步分析。


    如果我的建议对您有帮助、请点击采纳、祝您生活愉快

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(3条)

报告相同问题?

问题事件

  • 系统已结题 5月2日
  • 已采纳回答 4月24日
  • 修改了问题 4月11日
  • 创建了问题 4月11日

悬赏问题

  • ¥20 Apache poi使用问题
  • ¥21 matlab怎么求时域信号的二阶导数
  • ¥15 判断两个表是否完全相同
  • ¥15 java map类型数据格式,如何快速通过前缀匹配元素
  • ¥15 stc12c5a60s2、QMC5883L、LCD1602组合测量磁场所需程序
  • ¥20 Win11测试yolov4,“找不到nvcuda.dll”怎么办?
  • ¥15 simulink绘制bode图
  • ¥15 php_network_getaddresses: getaddrinfo failed: Name or service not known
  • ¥15 用msg发消息出现的问题
  • ¥15 unity3d机械臂