m0_74982612 2023-04-15 16:07 采纳率: 100%
浏览 14
已结题

C链表问题-建立学生信息列表

本题要求实现一个将输入的学生成绩组织成单向链表的简单函数。

函数接口定义:

void input();

该函数利用scanf从输入中获取学生的信息,并将其组织成单向链表。链表节点结构定义如下:

struct stud_node {
    int              num;      /*学号*/
    char             name[20]; /*姓名*/
    int              score;    /*成绩*/
    struct stud_node *next;    /*指向下个结点的指针*/
};

单向链表的头尾指针保存在全局变量headtail中。

输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};
struct stud_node *head, *tail;

void input();

int main()
{
    struct stud_node *p;
    
    head = tail = NULL;
    input();
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0

输出样例:

1 zhang 78
2 wang 80
3 li 75
4 zhao 85

错误代码

void input()
{
    int num;
    struct stud_node *p,*pre,*s;
    
    scanf("%d",&num);
    while(num!=0)
    {
        s=head->next;
        while(s!=NULL)
        {
            pre=s;
            s=s->next;
        }
        p=(struct stud_node *)malloc(sizeof(struct stud_node));
        p->num=num;
        scanf("%s%d",p->name,&p->score);
        p->next=pre->next;
        pre->next=p;
        scanf("%d",&num);
    }
}
  • 写回答

3条回答 默认 最新

  • 社区专家-Monster-XH 2023-04-15 16:23
    关注

    基于Monster 组和GPT的调写:

    img


    修改如下:

    void input()
    {
        int num;
        struct stud_node* p;
    
        scanf("%d", &num);
        while (num != 0) {
            p = (struct stud_node*)malloc(sizeof(struct stud_node));
            p->num = num;
            scanf("%s %d", p->name, &p->score);
            p->next = NULL;
    
            if (head == NULL) {
                head = tail = p;
            } else {
                tail->next = p;
                tail = p;
            }
    
            scanf("%d", &num);
        }
    }
    
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(2条)

报告相同问题?

问题事件

  • 系统已结题 4月23日
  • 已采纳回答 4月15日
  • 创建了问题 4月15日

悬赏问题

  • ¥15 有两个非常“自以为是”烦人的问题急期待大家解决!
  • ¥30 STM32 INMP441无法读取数据
  • ¥100 求汇川机器人IRCB300控制器和示教器同版本升级固件文件升级包
  • ¥15 用visualstudio2022创建vue项目后无法启动
  • ¥15 x趋于0时tanx-sinx极限可以拆开算吗
  • ¥500 把面具戴到人脸上,请大家贡献智慧,别用大模型回答,大模型的答案没啥用
  • ¥15 任意一个散点图自己下载其js脚本文件并做成独立的案例页面,不要作在线的,要离线状态。
  • ¥15 各位 帮我看看如何写代码,打出来的图形要和如下图呈现的一样,急
  • ¥30 c#打开word开启修订并实时显示批注
  • ¥15 如何解决ldsc的这条报错/index error