题目描述
现在棋盘的大小不一定,由p,q给出,并且在棋盘中将出现障碍物(限制马的行动,与象棋走法相同)
输入
第一行输入n表示有n组测试数据。
每组测试数据第一行输入2个整数p,q,表示棋盘的大小(1<=p,q<=100)。
每组测试数据第二行输入4个整数,表示马的起点位置与终点位置。(位置的取值范围同p,q)
第三行输入m表示图中有多少障碍。
接着跟着m行,表示障碍的坐标。
输出
马从起点走到终点所需的最小步数。
如果马走不到终点,则输入“can not reach!”
样例输入
2
9 10
1 1 2 3
0
9 10
1 1 2 3
8
1 2
2 2
3 3
3 4
1 4
3 2
2 4
1 3
样例输出
1
can not reach!
我的思路是:一开始把马的起始点加入队列,然后用广搜的思想把此点能到达的其他点加入队列,这里需要一个二维数组,将除阻挡点赋值为-1外,其它点都初始化为0,用来记录此点是第几步到达的,然后再入队,如果加入过队列当中,就不需要再加入了,马成功到达终点,或者搜索到了终点,搜索即停止,然后输出相应答案即可。但我不知道为什么答案错误,求解答!
Expected | Yours
25 24
#include <iostream>
#include <iomanip>
#include <cstdio>
#define MVNum 105
using namespace std;
int dx[8] = {-2,-2, -1, 1, 2, 2, 1, -1};
int dy[8] = {-1,1, -2, -2, 1, -1, 2, 2};
int m[2]= {1,-1};
typedef struct
{
int length,width;
int sx, sy, ex, ey,h;
int arcs[MVNum][MVNum];
} Graph;
bool visited[MVNum][MVNum];
bool right1(Graph &g,int nx, int ny)
{
return nx>=0&&nx<=g.length &&ny>= 0 && ny <=g.width && !visited[nx][ny];
}
bool right2(Graph &g,int x,int y,int i)
{
int nx,ny;
if(i<2)
nx=x+m[1];
else if(i>=2&&i<4)
ny=y+m[1];
else if(i>=4&&i<6)
nx=x+m[0];
else
ny=y+m[0];
return g.arcs[nx][ny]!=-1;
}
void BFS(Graph &g)
{
int Queue[MVNum * MVNum][2];
int front = 1, rear = 1;
Queue[rear][0]=g.sx;
Queue[rear][1]=g.sy;
rear++;
while (front < rear&&rear<=MVNum*MVNum)
{
int x = Queue[front][0];
int y = Queue[front][1];
front++;
if (x==g.ex&&y==g.ey)
{
cout<<g.arcs[x][y]<<endl;
return ;
}
for (int i = 0; i < 8; i++)
{
int nx = x + dx[i];
int ny = y + dy[i];
if (right1(g,nx, ny)&&right2(g,x,y,i) &&g.arcs[nx][ny]==0)
{
g.arcs[nx][ny] = g.arcs[x][y] + 1;
Queue[rear][0] = nx;
Queue[rear][1] = ny;
rear++;
}
}
}
cout<<"can not reach!"<<endl;
}
void destroy(Graph &g)
{
g.length=g.width=0;
}
int main()
{
Graph g;
int n;
cin>>n;
while (n--)
{
cin>>g.length>>g.width;
for (int i = 1; i <=g.length; i++)
{
for (int j = 1; j <=g.width; j++)
{
g.arcs[i][j]=0;
visited[i][j] = false;
}
}
cin>>g.sx>>g.sy>>g.ex>>g.ey;
cin>>g.h;
while (g.h--)
{
int x, y;
cin>>x>>y;
g.arcs[x][y]=-1;
visited[x][y] = true;
}
BFS(g);
destroy(g);
}
return 0;
}