Wordpress无法识别正确的PHP版本以进行更新

我在God4dy上安装了一个在PHP4上运行的Wordpress。</ p>

I 已经将Godaddy编程语言转换为PHP 5.2,但Wordpress更新页面仍显示此错误:</ p>


您无法更新,因为WordPress 3.2.1需要PHP 5.2.4版或 更高。 您正在运行版本4.4.9。</ p>
</ blockquote>

Godaddy帐户说正在使用PHP 5.2。</ p>

如何更新 Wordpress现在作为“更新”按钮不再显示?</ p>
</ div>

展开原文

原文

I have a Wordpress install on Godaddy that was on PHP4.

I have shifted the Godaddy programming language to PHP 5.2 but the Wordpress update page still shows this error:

You cannot update because WordPress 3.2.1 requires PHP version 5.2.4 or higher. You are running version 4.4.9.

The Godaddy account says PHP 5.2 is being used.

How can I update Wordpress now as the "Update" button is no longer showing?

douxie9347
douxie9347 好的谢谢。我把上面的代码放在测试版本中,它显示PHP版本是4.4所以我只能假设GoDaddy设置和内部帐户不正确。我已经进行了双重和三重检查,并且它说该帐户在PHP5上运行,但我想它不可能。谢谢您的帮助
接近 9 年之前 回复
doupang3062
doupang3062 另外,你可以使用<?phpphpinfo()?>-很好地了解将来调试类似的问题。
接近 9 年之前 回复
dongsheng8158
dongsheng8158 你确定PHP版本是否正确?使用<?phpechophpversion()?>在文档根目录中创建一个文件,并查看它显示的内容
接近 9 年之前 回复

1个回答



尽管GoDaddy可能会提供PHP5,但您必须在 .htaccess </ code>文件中设置它。 您的网站的根目录。</ p>

将此添加到.htaccess文件的顶部:</ p>

  AddType x-mapp-php5 .php \  nAddHandler应用程序/ x-httpd-php5 .php 
AddHandler cgi-php5 .php
</ code> </ pre>

注意:</ strong>您可能不需要 AddType </ code>行,如果您的网站出现500错误,则删除该行。</ p>
</ div>

展开原文

原文

Even though GoDaddy may offer PHP5, it is something you have to set in your .htaccess file at the root of your site.

Add this to the top of your .htaccess file:

AddType x-mapp-php5 .php
AddHandler application/x-httpd-php5 .php
AddHandler cgi-php5 .php

NOTE: you may not need the AddType line, if your site gives a 500 error, then remove that line.

drsqpko5286
drsqpko5286 看看这是否有帮助:ardamis.com/2009/07/25/ ...我不再是GoDaddy(感谢上帝),所以我无法验证。
接近 9 年之前 回复
drzil26260
drzil26260 我尝试过,但无论有没有初始的AddType线,它都无法正常工作?
接近 9 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问