Laravel 5.6 php版本冲突

我正在尝试在新环境中安装Laravel 5.6。 </ p>

在我的本地环境中,我设置的一切都很好。 当我去部署到Elastic Beanstalk时,我遇到了一个问题,依赖关系迫使服务器回到PHP v7.0.33。</ p>

Laravel的文档如何说5.6版本 需要PHP 7.1.3及更高版本,但是依赖项迫使我回到7.0.33?</ p>

以下是Composer中PHP的依赖列表(我删除了不相关的依赖项):</ p> \ n

  composer / ca-bundle 1.1.4需要php(^ 5.3.2 || ^ 7.0)
composer / composer 1.8.4需要php(^ 5.3.2 || ^ 7.0)
composer / semver 1.4.2需要php(^ 5.3.2 || ^ 7.0)
composer / spdx-licenses 1.5.0需要php(^ 5.3.2 || ^ 7.0)
composer / xdebug-handler 1.3.2需要php( ^ 5.3.2 || ^ 7.0)

filp / whoops 2.3.1需要php(^ 5.5.9 || ^ 7.0)
fzaninotto / faker v1.8.0需要php(^ 5.3.3 || ^ 7.0)
hamcrest / hamcrest-php v2.0.0需要php(^ 5.3 || ^ 7.0)
phar-io / manifest 1.0.3需要php(^ 5.6 || ^ 7.0)
phar-io / version 2.0.1 requir es php(^ 5.6 || ^ 7.0)
phpdocumentor / reflection-docblock 4.3.0需要php(^ 7.0)
phpdocumentor / type-resolver 0.4.0需要php(^ 5.5 || ^ 7.0)
phpspec / prophecy 1.8.0需要php(^ 5.3 | ^ 7.0)
ramsey / uuid 3.8.0需要php(^ 5.4 || ^ 7.0)
sebastian / code-unit-reverse-lookup 1.0.1需要php(^ 5.6 || ^ 7.0)
seld / jsonlint 1.7.1 需要php(^ 5.3 || ^ 7.0)
theseer / tokenizer 1.1.0需要php(^ 7.0)
tijsverkoyen / css-to-inline-styles 2.2.1需要php(^ 5.5 || ^ 7.0)
webmozart / assert 1.4.0需要php(^ 5.3.3 || ^ 7.0)
</ code> </ pre>

在我看来,所有这些依赖项都不允许安装高于最高 PHP 7.0的版本。 我读错了吗? </ p>
</ div>

展开原文

原文

I am trying to install Laravel 5.6 in my new environment.

In my local environment, I have everything set up just fine. When I go to deploy to Elastic Beanstalk, I am running into a problem where the dependencies are forcing the server back into PHP v7.0.33.

How can the documentation of Laravel say that version 5.6 requires PHP 7.1.3 and up but the dependencies force me back to 7.0.33?

Here is the dependency list for PHP from Composer (I removed unrelated dependencies):

composer/ca-bundle  1.1.4       requires  php (^5.3.2 || ^7.0)
composer/composer   1.8.4       requires  php (^5.3.2 || ^7.0)
composer/semver     1.4.2       requires  php (^5.3.2 || ^7.0)
composer/spdx-licenses  1.5.0       requires  php (^5.3.2 || ^7.0)
composer/xdebug-handler 1.3.2       requires  php (^5.3.2 || ^7.0)
filp/whoops 2.3.1       requires  php (^5.5.9 || ^7.0)
fzaninotto/faker  v1.8.0      requires  php (^5.3.3 || ^7.0)
hamcrest/hamcrest-php  v2.0.0      requires  php (^5.3||^7.0)
phar-io/manifest   1.0.3       requires  php (^5.6 || ^7.0)
phar-io/version    2.0.1       requires  php (^5.6 || ^7.0)
phpdocumentor/reflection-docblock   4.3.0       requires  php (^7.0)
phpdocumentor/type-resolver    0.4.0       requires  php (^5.5 || ^7.0)
phpspec/prophecy    1.8.0       requires  php (^5.3|^7.0)
ramsey/uuid     3.8.0       requires  php (^5.4 || ^7.0)
sebastian/code-unit-reverse-lookup  1.0.1       requires  php (^5.6 || ^7.0)
seld/jsonlint  1.7.1       requires  php (^5.3 || ^7.0)
theseer/tokenizer    1.1.0       requires  php (^7.0)
tijsverkoyen/css-to-inline-styles  2.2.1       requires  php (^5.5 || ^7.0)
webmozart/assert   1.4.0       requires  php (^5.3.3 || ^7.0)

It seems to me that all these dependencies would not allow for an installation higher than the highest version of PHP 7.0. Am I reading this wrong?

doumi1884
doumi1884 试试php-v
一年多之前 回复
douzuan5365
douzuan5365 当我选择安装版本7.2时,ElasticBeanstalk版本如何能够是7.0.33?我不明白。
一年多之前 回复
dongxu4580
dongxu4580 不。这意味着您的PHP版本实际上是7.0.33,而且doctrine/inflector需要PHP版本>=7.1。Composer无法更改您的php可执行文件/版本。
一年多之前 回复
dongzhi5386
dongzhi5386 我正在尝试将我的Laravel5.6应用程序部署到ElasticBeanstalk环境中。我将服务器设置为PHP7.2服务器,但是我收到如下错误“doctrine/inflectorv1.3.0需要php^7.1->您的PHP版本(7.0.33)不满足该要求。”我唯一能想到的是,一些依赖性迫使服务器回到php版本7.0.33
一年多之前 回复
dongpao1873
dongpao1873 你能分享更多背景吗?是什么让你认为依赖“强迫”某些东西?是否有任何错误信息?
一年多之前 回复
duanfeng3879
duanfeng3879 然后我无法弄清楚我的生活是什么让服务器保持在PHPv7.0.33。根据弹性Beanstalk,它意味着在7.2。有任何想法吗?
一年多之前 回复
doure8758
doure8758 ^7.0表示它将匹配此范围内的所有PHP版本:>=7.0.0<8.0.0..
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐