doujilou3903
2014-01-10 11:10
浏览 76
已采纳

使用包装器访问Microsoft FTP服务上的文件时“无法打开流:FTP服务器报告550”

In PHP, you have wrappers for ftp and ftps to allow you access files on an FTP using fopen.

I want to use the wrapper to download a file as a stream.

My simplified code:

// eg. $url = "ftp://username:password@server.com/directory-with-dash/file.mp3";
$url = 'ftp://' . urlencode($username) . ':' . urlencode($password) . '@' . $server . $path . '/' . $filename;
$ctx = stream_context_create(array('ftp' => array('resume_pos' => 0)));
$fin = fopen($url, 'r', false, $ctx);

Error:

Warning: fopen(ftp://...@server.com/directory-with-dash/file.mp3): failed to open stream: FTP server reports 550 /directory-with-dash/file.mp3: The system cannot find the path specified. in /var/www/ftp.php on line 4

More Info:

  • The same url works fine when used with wget on the same machine.
  • Using PHP's FTP extension to download files works fine
  • FTP server responds with 220 Microsoft FTP Service and 215 Windows_NT
  • FTP server can handle passive mode
  • Using filesize($url); results in Warning: filesize(): stat failed for...
  • allow_url_fopen setting is On
  • The same code worked fine against a different FTP-server, 215 UNIX Type: L8

What might be causing the problem?

Edit:

I have noticed that the Microsoft FTP Service doesn't place you in the root folder when you connect to the FTP, but in a subfolder:

/username

This subfolder must not be in the URL when you use wget or a web browser:

ftp://username:password@server.com/username/directory-with-dash/file.mp3 // Not available in Chrome ftp://username:password@server.com/directory-with-dash/file.mp3 // Works fine in Chrome

I have tried both urls in the PHP-code, but I get the same error still. (I typed it wrong)

1条回答 默认 最新

相关推荐 更多相似问题