Composer安装mongodb版本问题

我想使用composer为我的PHP项目安装一个包。</ p>

我首先尝试了这个:</ p>

composer require jenssegers / mongodb --ignore-platform-reqs </ code> </ p>

但它没有' 使用这种方法。 因此,我删除了mongodb并在安装后再次安装。</ p>

但是这种方法不起作用。</ p>

  composer install 
\ nProblem 1
  • mongodb / mongodb的安装请求1.4.2 - &gt; 可以通过mongodb / mongodb [1.4.2]来满足。
  • mongodb / mongodb 1.4.2需要ext-mongodb ^ 1.5.0 - &gt; 您的系统中缺少所请求的PHP扩展名mongodb。 问题2
  • mongodb / mongodb 1.4.2需要ext-mongodb ^ 1.5.0 - &gt; 您的系统中缺少所请求的PHP扩展名mongodb。
  • jenssegers / mongodb v3.5.0需要mongodb / mongodb ^ 1.0.0 - &gt; mongodb / mongodb [1.4.2]可以满足。
  • jenssegers / mongodb v3.5.0的安装请求 - &gt; jenssegers / mongodb [v3.5.0]可以满足。 </ code> </ pre> </ div>

展开原文

原文

I want to install a package using composer for my PHP project.

I tried this first:

composer require jenssegers/mongodb --ignore-platform-reqs

But it doesn't work with this method. Therefore, I removed the mongodb and after install again.

But it doesn't work this method.

composer install

Problem 1
    - Installation request for mongodb/mongodb 1.4.2 -> satisfiable by mongodb/mongodb[1.4.2].
    - mongodb/mongodb 1.4.2 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb is missing from your system.
  Problem 2
    - mongodb/mongodb 1.4.2 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb is missing from your system.
    - jenssegers/mongodb v3.5.0 requires mongodb/mongodb ^1.0.0 -> satisfiable by mongodb/mongodb[1.4.2].
    - Installation request for jenssegers/mongodb v3.5.0 -> satisfiable by jenssegers/mongodb[v3.5.0].

dongliao1948
dongliao1948 同样的问题,但我的问题没有解决,它继续。
大约一年之前 回复
douxinghuai3150
douxinghuai3150 $Composer的可能重复找不到mongodb扩展名,需要Mongodb扩展名
一年多之前 回复
doutou7961
doutou7961 对不起,我无法理解你想说的话。也许会有其他人愿意帮助你。
一年多之前 回复
douhuang3833
douhuang3833 安装不会停止peclinstallmongodb的错误。但是当我说在PhpStorm中安装composer时,会出现上述错误。
一年多之前 回复
douying8666
douying8666 有错误信息吗?
一年多之前 回复
douye9822
douye9822 是的,我试过这种方式。
一年多之前 回复
doushangan3690
doushangan3690 您是否尝试安装ext-mongodb,例如用像peclinstallmongodb这样的命令?如果该库需要它,你必须提供它。
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐