duanping3587
duanping3587
2015-07-22 12:31

找不到 - 在此服务器上找不到请求的URL / app / example

  • localhost
  • vagrant
  • php
  • symfony

I have followed the tutorial to get started with Symfony

https://symfony.com/doc/current/quick_tour/the_big_picture.html

and I have first set up a development environment using Vagrant: I created the virtual machine Ubuntu, and it seems that the files in the virtual machine are synchronised with my current Symfony project directory.

When I try to start the server locally from the project folder with the following command:

php console server:run

or (depending on my current directory)

php app/console server:run

I get the following error/warning:

[Symfony\Component\Debug\Exception\ContextErrorException]
Warning: date_default_timezone_get(): It is not safe to rely on the system'
s timezone settings. You are required to use the date.timezone setting or
the date_default_timezone_set() function. In case you used any of those me
thods and you are still getting this warning, you most likely misspelled th
e timezone identifier. We selected the timezone 'UTC' for now, but please s
et date.timezone to select your timezone.

But apparently this is not a problem, and it is not my actual problem.

I have associated the port 80 of the virtual machine with the port 4567 in my local computer, as explained in the tutorial of Vagrant, by typing the following command in the Vagrantfile:

config.vm.network :forwarded_port, guest: 80, host: 4567

Now, in the Symfony tutorial I am following, to see the initial page, I have to type the following command in the browser URL entry box:

http://localhost:8000/app/example

But it does not work, because of course I need to use another port, so I try with:

 http://localhost:4567/app/example

and I get the following page:

enter image description here

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

1条回答

为你推荐