一个脚本上的“MySQL PHP扩展不可用”错误,而其他一切工作正常

在Ubuntu 16.04 AWS实例上,一个WordPress网站工作得很好。 当我尝试安装另一个IMS(机构管理系统)时,安装失败,自安装程序显示以下错误:</ p>

必需 - MySQL PHP扩展可用</ strong >(不可用)</ p>

我的php版本: 7.0.33-0ubuntu0.16.04.5 </ code> </ p>

我的MySQL版本 : 14.14 Distrib 5.7.27,for Linux(x86_64)使用EditLine包装器</ code> </ p>

我尝试更改 php.ini </ code>文件。

取消注释行</ p>

extension = mysql.so </ code> </ p>

虽然当我去了该位置,即 / usr / lib / php / 20151012 </ code>,没有名为 mysql.so </ code>的文件。 </ p>

有一个名为 mysqli.so </ code>的文件,因此我将该行更改为</ p>

extension = mysqli.so </ code> </ p>

然后重新启动apache2服务但无济于事。 仍然存在相同的错误:</ p>

必需 - MySQL PHP扩展可用</ strong>(不可用)</ p>
</ div>

展开原文

原文

On Ubuntu 16.04 AWS instance, a WordPress website is working just fine. When I tried to install another IMS (institute management system), it failed to install and the self-installer showed the following error:

Required - MySQL PHP extension available (Not Available)

My php version: 7.0.33-0ubuntu0.16.04.5

My MySQL version: 14.14 Distrib 5.7.27, for Linux (x86_64) using EditLine wrapper

I have tried changing the php.ini file. Uncommented the line

extension=mysql.so

Although when I went to the location, i.e, /usr/lib/php/20151012, there was no file named mysql.so.

There was a file named mysqli.so, so I then changed the line to

extension=mysqli.so

and then restarted the apache2 service but to no avail. There is still the same error:

Required - MySQL PHP extension available (Not Available)

1个回答



PHP 7.0+中不再提供MySQL扩展。 如果您有较旧的代码,则需要更新或升级。</ p>

特别</ strong>对于 </ strong>的旧WordPress安装非常重要</ strong> 如果您不保持警惕,请使用自动攻击工具进行攻击。</ p>
</ div>

展开原文

原文

The MySQL extension is no longer available in PHP 7.0+. If you have older code, you'll need to update or upgrade.

This is especially important for older WordPress installs that will be compromised by automatic attack tools if you're not vigilant about staying patched.

dssqq82402
dssqq82402 任何使用mysql_query的东西都可能充满了SQL注入漏洞,需要升级和完整的审计。 也许升级CodeIgniter版本会有所帮助。
大约一年之前 回复
dousou2897
dousou2897 不,先生,这不是WordPress。 这是我需要运行的CodeIgniter中的另一个项目。
大约一年之前 回复
dongtang4019
dongtang4019 如果它是WordPress你真的不想安装旧代码。 这太危险了,因为如果没有修补和更新,它几乎可能立即被攻击并受到攻击。
大约一年之前 回复
doushenxu7294
doushenxu7294 但我还没弄清楚如何生成该文件(编译php源等)。
一年多之前 回复
dtch60248
dtch60248 是的,我理解但是现在,我只需要安装旧的代码。 我在网上浏览时收集的内容,我需要一个名为mysql.so的扩展文件,它可能能够帮助我运行该代码。
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐