无法启用mysqli扩展 - PHP 7.1.12,无法连接到db

我在Fedora 27上安装了LAMP(一切都通过dnf / yum)但是由于某种原因,mysqli扩展被禁用或者没有 安装(我怀疑)当我试图打开phpMyAdmin我收到此错误:</ p>


phpMyAdmin - 错误</ p>

缺少mysqli扩展名。 请检查您的PHP配置。
有关详细信息,请参阅我们的文档。</ p>
</ blockquote>

我已经读过mysqli应该包含在php包中,但是没有< / p>


extension = php_mysqli.dll </ p>
</ blockquote>

在php.ini中(只需将此行添加到文件中即可) 或者工作)
我如何启用mysqli呢?</ p>
</ div>

展开原文

原文

I have installed LAMP (everything through dnf/yum) on Fedora 27 but for some reason mysqli extension is disabled or not installed (which i doubt) When I'm trying to open phpMyAdmin i got this error:

phpMyAdmin - Error

The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.

I've read that mysqli should be included in php package, however there is no

extension=php_mysqli.dll

in php.ini (simply adding this line to file doesn't work either) How can I enable mysqli then?

1个回答



.dll文件用于windows,你想要.so文件。 你想要这样的东西:</ p>

  extension = mysqli.so 
</ code> </ pre>

您可能还需要指定模块 目录:</ p>

  extension_dir = / path / to / your / php / extensions / no-debug-non-zts-whatever / 
</ code> </ pre> \ n

请注意,根据您的服务器配置,您可能还必须重新启动Web和/或PHP服务。</ p>
</ div>

展开原文

原文

.dll files are for windows, you want .so files. You want something like this:

extension = mysqli.so

You may also have to specify the module directory:

extension_dir = /path/to/your/php/extensions/no-debug-non-zts-whatever/

Note, depending on your server configuration, you may also have to restart your web and/or PHP service.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐