doujin4031
2016-08-02 15:58
浏览 148
已采纳

使用ansible抛出错误来运行php脚本

I am trying to run a php script on a remote server using ansible. Running the script with the ansible user (which ansible uses to login to the server) works perfectly. The ansible task however fails when there are include statements in my php script.

My php script lays in

/srv/project

it tries to include

includes/someLibrary.php
Everything works fine when running the script as any user with the correct access rights but when running it via an ansible task
- name: run script
  shell: 'php /srv/project/script.php'

it fails with:

failed to open stream: No such file or directory in /srv/project/includes/someLibrary.php

Running a very basic php script works nicely though.

图片转代码服务由CSDN问答提供 功能建议

我正在尝试使用ansible在远程服务器上运行php脚本。 使用ansible用户运行脚本( ansible用于登录服务器的工作完美。 然而,当我的php脚本中包含语句时,ansible任务失败。

我的php脚本位于

 / srv / project  
 
  

尝试包含

 includes / someLibrary.php  
当所有用户都具有正确的访问权限但通过ansible任务运行时,所有工作都正常工作
 \  n 
 
- name:运行脚本
 shell:'php /srv/project/script.php'
nn

失败:

 无法打开流:/srv/project/includes/someLibrary.php中没有这样的文件或目录 
 
 

运行一个非常基本的PHP脚本可以很好地工作。

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douchenbiao0916 2016-08-03 08:03
    已采纳

    I just found the solution to the problem. The problem was that when I executed the script by hand, I connected to the server and cd'd into the /srv/project directory before calling php script.php PHPs include in this case looks in the current directory for the files I want to include. When ansible connects to the server it did not change the directory thus producing the no such file or directory error. The solution to this is simple as the shell module takes a chdir as an argument to change the directory to the one specified before running the command.

    My ansible task now looks as follows:

    - name: run script
      shell: 'php /srv/project/script.php'
      args:
        chdir: '/srv/project'
    

    Thanks everyone for your help!

    打赏 评论
  • dongxi2163 2016-08-02 20:51

    Ansible runs under a non-interactive ssh session, and thus does not apply user environment settings (eg, .bashrc, .bash_profile). This is typically the cause of different behavior when running interactively vs. not. Check the difference between an interactive printenv and raw: printenv via Ansible, and you'll probably find what needs to be set (via an ansible task/play environment: block) to get things working.

    打赏 评论

相关推荐 更多相似问题