dtu15253 2014-12-01 04:45
浏览 384
已采纳

Cygwin上的Symfony2 - PHP分段错误

I struggle to be able to run PHP client line interface on Cygwin. I receive constantly Segmentation fault error. But some of functions are correctly done - I cannot say when does it happen.

If somebody had this error, please give me any clue to correctly run PHP CLI under cygwin.

Thanks in advance!

EDIT

I Receive stackdump, but I don't know if it tells anything:

Exception: STATUS_ACCESS_VIOLATION at eip=603B7AC6
eax=0000000A ebx=FFE42FFF ecx=002853E0 edx=FFE43000 esi=00000000 edi=FFE43000
ebp=002853E2 esp=00285240 program=C:\cygwin\bin\php.exe, pid 10056, thread main
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame     Function  Args
002853E2  603B7AC6 (022A018F, 02D40284, 0348030B, 0374034D)
00040002  00F30055 (00340000, 01E00000, 020C0000, 00360000)

Moreover I tried to limit in php.ini

pcre.recursion_limit=1000    
  • no effect.

It crashes every time when I work with client line interface. If I run it through Apache2 there is no problem.

How can I debug it effectively?

EDIT

I run it with php-cgi, where I receive the html output with error description:

ContextErrorException: Warning: Invalid argument supplied for foreach() in ...

Having this information I guess that there is a problem with input arguments. If I run scripts without arguments from console I don't receive segmentation fault.

This is Symfony framework and those scripts run like a charm on windows and ubuntu on console. So I guess: - there is something wrong with PHP settings - there is something wrong with console on Cygwin

Any idea how can I debug it more?

  • 写回答

1条回答 默认 最新

    报告相同问题?

    相关推荐 更多相似问题

    悬赏问题

    • ¥15 关于#Python#的问题,如何解决?
    • ¥15 CMD 生成TXT内容输出成一行
    • ¥20 关于#pandas#的问题,如何解决?(语言-python)
    • ¥15 eclipse为什么导入不了RAR阿
    • ¥30 c语言设计井字棋小游戏
    • ¥15 关于属性关联的双极容度多属性决策vikor方法的公式
    • ¥15 10吨190马力爆炸品运输车,以80km/h的速度行驶1个小时输出的动能或者做的功是多少?
    • ¥15 《phthon编程从入门到实践》第十八章,从django入手,learning_log,ModuleNotFoundError: No module named 'learning_logs
    • ¥15 echarts 放入折叠面板宽高的问题
    • ¥50 求帮配置Django项目配置环境