doubaoguo7469
2012-11-26 08:55 阅读 22
已采纳

PHP适用于Web但不适用于本地apache(linux mint)

I tried to run PHP form tutorial on local apache, while it works on my web apache it won't work on local. In my local machine I get the following error:

"Notice: Undefined index: formSubmit in /opt/lampp/htdocs/rw/form/myform1.php on line 2".

I have appended the lampp user and group and tried to set privileges from 644 to 777 with no result. Any help?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

2条回答 默认 最新

  • 已采纳
    duanfu4446 duanfu4446 2012-11-26 09:05

    Alex, It is not an error. That is just a notice, kind of "warning". It is because the php.ini settings in you local machine is set to show you notices, along with errors.
    You could check if that value has been set, in order to avoid that notice. To do that, you can use isset():

    isset() function in PHP determines whether a variable is set and is not NULL. It returns a Boolean value, that is, if the variable is set it will return true and if the variable value is null it will return false.

    Ref: http://notesofgenius.com/how-fix-php-notice-undefined-index/

    To hide notices:
    Now you have a php.ini setting error_reporting set to include E_NOTICE. You can choose not to show notices by setting error_reporting to E_ALL & ~E_NOTICE

    点赞 评论 复制链接分享
  • dongzai0020 dongzai0020 2012-11-26 08:57

    Check that the variable is set before getting it from array :

    if(isset($_POST['formSubmit']) && $_POST['formSubmit'])
    
    点赞 评论 复制链接分享

相关推荐