douzhi7451
douzhi7451
2017-05-24 23:54
浏览 303
已采纳

默认情况下,apache2中没有加载index.php

I just installed Ubuntu 17.04 and set up my LAMP server w/ PHP7 and the PHP modules enabled for Apache2.

When I go to http://localhost/ it defaults to the index.html that is present in /var/www/html and not the index.php that is there. When I go to http://localhost/index.php the php file loads just fine and the php script executes.

In looking at other posts ( index.php not loading by default ) I saw that the preferred solution is to edit the /etc/apache2/mods-enabled/dir.conf file to move the index.php before the index.html in the DirectoryIndex entry.

<IfModule mod_dir.c>
    DirectoryIndex index.php index.html index.cgi index.pl index.xhtml index.htm
</IfModule>

So I did this and saved the file as sudo, restarted the apache service as well as tried restarting the computer and it still serves the index.html first. Any idea? Should I use the .htaccess file solution instead? Thanks!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douluyezhen4512
    douluyezhen4512 2017-05-25 00:01
    已采纳

    This is likely a caching issue in your browser when you go to http://localhost/ try pressing Ctrl + F5

    点赞 评论

相关推荐