sqlserver mdf向上兼容附加数据库(无法打开数据库 'xxxxx' 版本 628。请将该数据库升级为最新版本。) 5C

要附加的数据库版本为628,我的数据库版本是654,原本低版本的数据库附加到高版本的数据库中是兼容的,但我附加之后,打不开附加的数据库,提示打不开对应的数据库版本为628的数据库,请升级该数据库到最新版本????在网上也找了一些解决方案,但都没能解决,有大神解决过类似问题吗?帮帮忙图片说明

sql

1个回答

原来的计算机如果还在的话,导出数据库再导入是最简单的。
有几个办法,一个是创建一个同名的数据库,再关机,在pe系统里直接覆盖文件。
还有一个是创建数据库,附加,在属性里面选择兼容性,选择兼容级别,再导入。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问