winp668
388号程序猴
采纳率0%
2019-10-06 15:28 阅读 1.6k

Ubuntu18.04无法安装python2.7

Ubuntu18.04环境下需要安装python2.7
输入sudo apt insatll python2.7 无法安装
提示依赖项错误,请问该如何解决?

图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • caozhy 从今以后生命中的每一秒都属于我爱的人 2019-10-06 15:48

    ubuntu 18.04默认已经有了py3.6,你得先卸载了再安装2.7,或者用anaconda的安装包,配置两个环境共存

    点赞 评论 复制链接分享
  • hjs218 Json-Huang 2019-10-06 16:00

    使用aptitude 工具试试
    sudo apt-get install aptitude
    然后:sudo aptitude install python2.7

    点赞 评论 复制链接分享
  • hellowaichan hellowaichan 2019-10-06 22:16

    我的安裝了沒有問題啊

    点赞 评论 复制链接分享
  • milaijiang milaijiang 2019-10-21 01:14

    换源,然后在软件和更新里把更新那栏前两个选上,然后exit,能他更新完,然后sudo apt update sudo apt upgrade。。。然后去py的官网下tgz包,解压,make

    点赞 评论 复制链接分享

相关推荐