dongyang0005
dongyang0005
2010-09-15 12:31

FTP /主机修改我的代码[重复]

已采纳

Possible Duplicate:
How can I stop Filezilla changing my linebreaks?
SFTP from within PHP

I have a php file which work in local, when I send it online it doesn't work so I download it back and it's now on a single line...

Basically before I send it via FileZilla FTP :

<?php
          code
          code
          code
?>

Once I download it back

<?phpcodecodecode?>

Any idea if it's FTP Client related, host related, encoding related...etc...

I've never seen that in 4 years of coding, on 10-20 different hosts.

Edit I code using NotePad++, I send with FileZilla and the host is iWeb, I've formatted my computer yesterday so it may be a weird setting I have not changed or something like that...

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • douhe6181 douhe6181 11年前

    It's probably changing your linebreaks from Windows to UNIX style (although NotePad++ should be able to display both styles).

    Try the settings from this old question: How can I stop Filezilla changing my linebreaks?

    点赞 评论 复制链接分享
  • du0204 du0204 11年前

    It may be that, I tried an old trick, I opened each file, copy/paster into a new file (which was Utf-8/Unix format) and saved it under the last name and it worked...you are probably right it was the Unix format I would say.

    点赞 评论 复制链接分享

为你推荐