Laravel Valet不报告错误,但我看不到我的Laravel应用程序

首先,我正在使用Homebrew的PHP 7.1运行macOS High Sierra </ p>

我也遵循了代客的文件,并尝试了这些问题:代客(Laravel):无法找到DNS地址 Laravel valet它有效 aaaaaand,尽管如此,当我导航到project.dev时,我只是得到了”它有效!“ 我遇到ping问题,但结果是macOS防火墙中的Stealth Mode。</ p>

我在这个目录中设置了Laravel,所以我应该得到默认的启动页面,对吧 ?</ p>

另外,如果它很重要,这里是我用来安装PHP 7.1的行: brew install php71 --with-httpd --with-pear --with- postgresql --with-thread-safety --with-homebrew-curl </ code> </ p>
</ div>

展开原文

原文

First, I'm running macOS High Sierra, with Homebrew's PHP 7.1

I've also followed the Valet documentation to the letter, as well as trying what was on these asks: Valet (Laravel): DNS address can not be found and Laravel valet It works aaaaaand, despite all of that, when I navigate to project.dev, I just get "It works!" I was having issues pinging, but that turned out to be Stealth Mode in the macOS Firewall.

I have Laravel set up in this directory, so I SHOULD be getting the default splash page, right?

Also, in case it matters, here's the line I used to install PHP 7.1 itself: brew install php71 --with-httpd --with-pear --with-postgresql --with-thread-safety --with-homebrew-curl

doujiling4377
doujiling4377 让我们在聊天中继续讨论。
接近 3 年之前 回复
dongshao6591
dongshao6591 完成,完成和完成,我尝试任何事情后都一直在运行代客重启。
接近 3 年之前 回复
doz97171
doz97171 此外,通过运行apachectlstop然后重启代客,确保您的内置apache2服务器(HighSierra)已停止。值得一试
接近 3 年之前 回复
dongzhao2725
dongzhao2725 啊!我认为你的nginx虚拟主机没有设置!你有没有关注这个?laravel.com/docs/5.5/valet#serving-sites也可以按照文档中的说明尝试链接。确保您的站点位于默认目录〜/Sites/..
接近 3 年之前 回复
douheng8629
douheng8629 我已经做了;我为不清楚而道歉。display_errors设置为On,级别设置为E_ALL。
接近 3 年之前 回复
dongxing7083
dongxing7083 显示E_ALL和display_error=On在php.ini上不是相同的常量我还是建议检查一下。
接近 3 年之前 回复
dongxixiu9134
dongxixiu9134 我确实将错误设置为显示E_ALL,并且我的命令行或浏览器中没有错误。
接近 3 年之前 回复
doujiao7483
doujiao7483 你能检查你的php.ini是否设置为显示错误?display_errors=On
接近 3 年之前 回复

2个回答



您应该检查与防火墙相关的设置。 确保允许ping和ICMP。</ p>

要在Mac上进行检查:</ p>


系统首选项&gt; 安全与安全 隐私&gt; 防火墙&gt; 防火墙选项</ p>
</ blockquote>
</ div>

展开原文

原文

You should check your settings related to firewall. Make sure you are allowing pings and ICMP.

To check it on a Mac :

System Preference > Security & Privacy > Firewall > Firewall Options

dougou7782
dougou7782 让我们在聊天中继续讨论。
接近 3 年之前 回复
dqysi86208
dqysi86208 我真的不能指出问题,因为你尝试了trobleshootings。 但我建议你按照这个答案指南,stackoverflow.com / a / 42976841/4465062也许你错过了一些步骤。
接近 3 年之前 回复
dongyan1974
dongyan1974 php71 nginx和dnsmasq都在运行。 (字符限制阻止我粘贴该命令的完整输出。)httpd也特别列为已停止。 所有3项服务都以root身份运行; 那是问题吗?
接近 3 年之前 回复
dongqiuwei8667
dongqiuwei8667 你用brew检查服务列表了吗? > brew services list命令将向您显示服务。 有些可能会停止。
接近 3 年之前 回复
doudi4621
doudi4621 好吧,nuked / vendor并运行作曲家更新,重新启动代客,并且,为了确保缓存没有再次踢我的后端,我打开一个私人选项卡,再次转到project.dev并“它工作”>。
接近 3 年之前 回复
drvjlec1767
drvjlec1767 这可能与您的预编译文件有关。 让我们删除vendor文件夹中的compiled.php并从命令行运行composer update。如果有效,我将根据此编辑我的asnwer。 如果不是,我们会尝试提出另一种解决方案。
接近 3 年之前 回复
douyong1886
douyong1886 这照顾了ping问题,但我仍然没有看到Laravel飞溅:(但是,嘿,进展是进步,特别是在凌晨2点!)
接近 3 年之前 回复



这听起来像预先安装了macos的Apache正在端口80中运行。在启动代客之前,请确保Apache是 停止。 </ p>

您可以使用以下命令: sudo apachectl stop </ code>或 sudo apachectl -k stop </ code>来停止Apache,之后,您可以 继续你的代客流程。 </ p>

希望它有所帮助。 </ p>
</ div>

展开原文

原文

This sounds like the Apache that comes pre-installed with macos is running in the port 80. Before starting valet, make sure that Apache is stopped.

You can these commands: sudo apachectl stop or sudo apachectl -k stop to stop Apache, and after that, then you can proceed with your valet process.

Hope it helps.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐