dongxiao9583
2017-05-11 22:59
浏览 172
已采纳

WAMPServer安装 - phpMyAdmin登录时出错 - 错误#1193

I'm trying to set up WAMPServer for the first time on my personal computer to do some WordPress work. When I try to log into phpadmin with the root login, I get an error screen. The Error reads as such:

SQL query: Edit

SET lc_messages = 'en_US';

MySQL said:

1193 - Unknown system variable 'lc_messages'

I've tried running PHP version 7.0.10 and 5.6.25 but the errors occurred on both.

I'm running MySQL version 5.7.14

I've tried looking at a StackOverflow forum with the same issue, linked here, but none of the suggested fixes worked for me there, since I'm running a pretty updated version of phpMyAdmin.

图片转代码服务由CSDN问答提供 功能建议

我正在尝试在我的个人计算机上第一次设置WAMPServer来完成一些WordPress工作。 当我尝试使用root登录登录phpadmin时,出现错误屏幕。 错误读取如下:

SQL查询:编辑

SET lc_messages ='en_US';

MySQL说:

1193 - 未知系统变量'lc_messages'

我试过运行PHP 版本7.0.10和5.6.25但两者都发生了错误。

我正在运行MySQL版本5.7.14

我试过了 查看具有相同问题的StackOverflow论坛,链接这里,但没有一个建议的修复程序适用于我,因为我正在运行一个非常新的phpMyAdmin版本。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • doujiao3346 2017-05-12 08:20
    已采纳

    The correct name for that parameter is lc-messages note a hyphen and not an underscore.

    Have you amended anything in the 'my.ini'?

    RE: Your Comment

    Then potentially you have another MySQL runing or maybe just a rouge my.ini file on your system.

    Search for my.ini and if you find it anywhere other then inside the \wamp\ or \wamp64\ folders, remove or rename it. There should not be one outside the wamp folder structure.

    点赞 打赏 评论
  • doubi4435 2018-12-10 10:59

    Worked for me

    On my system there was another SQL SERVER was running, that was the problem.

    Simply go to WAMPMANAGER-> MySQL-> Use a port other than 3306

    (In my case, Wamp Manager automatically selected port 3308)

    click ok and restart the wamp server.

    点赞 打赏 评论

相关推荐 更多相似问题