运行PHP bin / magento deploy:mode:set production我在magento 2.1上遇到错误

我正在使用带有nginx的php7 </ p>

编译生成的代码时出错了 。 有关详细信息,请参阅错误日志。</ p>


命令返回非零退出代码:
/usr/bin/php7.0 -f / var / www / magento2 / bin / magento setup:di:compile </ code> </ p>
</ blockquote>
</ div>

展开原文

原文

I am using php7 with nginx

Something went wrong while compiling generated code. See the error log for details.

Command returned non-zero exit code: /usr/bin/php7.0 -f /var/www/magento2/bin/magento setup:di:compile

2个回答



尝试使用 -vvv </ code>开关运行失败命令(对于非常详细的输出)。 </ p>

  /usr/bin/php7.0 -f / var / www / magento2 / bin / magento setup:di:compile -vvv 
</ code> </ pre >

使用此命令,您至少应该得到比“发生错误...”更好的错误消息</ p>

很可能,只是memory_limit太低了 。 您可以通过在php命令中添加-d参数来增加php进程的内存限制:</ p>

  /usr/bin/php7.0 -d memory_limit = 1G -f  / var / www / magento2 / bin / magento setup:di:compile 
</ code> </ pre>

如果你运行deploy:mode:set production,编译将作为sub的startet 进程,你不能像这样增加内存限制(因为参数没有传递给子命令)</ p>

在这种情况下,你必须增加php配置中的内存限制 </ p>
</ div>

展开原文

原文

try to run the failing command with the -vvv switch (for very verbose output).

/usr/bin/php7.0 -f /var/www/magento2/bin/magento setup:di:compile -vvv

with this command you should at least get a better error message than "an error occurred..."

very likely, it's just the memory_limit being too low. You can increase the memory limit for a php process by adding the -d parameter to the php command:

/usr/bin/php7.0 -d memory_limit=1G -f /var/www/magento2/bin/magento setup:di:compile

if you run deploy:mode:set production, the compilation will be startet as a sub process and you can't increase the memory limit like this (since the parameter is not passed to the sub command)

in this case, you have to increase the memory limit in your php configuration

dtmtu02882
dtmtu02882 Ahahaha现在我无法部署,因为magento在构建此命令时使用了错误的PHP进程,而我无权更改INI。 如果不运行一堆配置错误的子进程,为什么没有其他方法可以部署呢?
2 年多之前 回复
dsfd3546
dsfd3546 那么,您是否执行了第一个命令并获得了实际的错误消息? 第二个只是一个假设。 ..
接近 4 年之前 回复



 命令返回非零退出代码:/usr/bin/php7.0 -f / var / www / magento2 /  bin / magento setup:di:compile 
</ code> </ pre>

在Magento 2世界中,此错误消息被广泛称为内存限制问题。 这就是为什么在Magento 2的要求中,他们建议我们设置</ p>

  memory_limit = 768M 
</ code> </ pre>

这就是 在几乎情况下运行Magento 2命令的完美尺寸。</ p>
</ div>

展开原文

原文

Command returned non-zero exit code: /usr/bin/php7.0 -f /var/www/magento2/bin/magento setup:di:compile

In Magento 2 world, this error message is widely-known as memory limit problem. That is why in Magento 2 requirement, they recommend us to set

memory_limit = 768M

That is the perfect size to run Magento 2 commands in almost situation.

douren9077
douren9077 我在1G内存限制中的限制
接近 4 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐