xxxxxxxxyrrrrrr
xxxxxxxxyrrrrrr
采纳率100%
2019-10-15 11:36

python3.6安装pypsa包时报错,无法安装。

已采纳

在使用pip install pypsa,安装报错如下图片说明图片说明

ERROR: Command errored out with exit status 1:
command: 'd:\python3\python.exe' 'd:\python3\lib\site-packages\pip_vendor\pep517_in_process.py' get_requires_for_build_wheel 'C:\Users\xyrrrr\AppData\Local\Temp\tmpk8s4cp1x'
cwd: C:\Users\xyrrrr\AppData\Local\Temp\pip-install-y9r5hyt9\cartopy
Complete output (3 lines):
setup.py:171: UserWarning: Unable to determine GEOS version. Ensure you have 3.3.3 or later installed, or installation may fail.
'.'.join(str(v) for v in GEOS_MIN_VERSION), ))
Proj 4.9.0 must be installed.


ERROR: Command errored out with exit status 1: 'd:\python3\python.exe' 'd:\python3\lib\site-packages\pip_vendor\pep517_in_process.py' get_requires_for_build_wheel 'C:\Users\xyrrrr\AppData\Local\Temp\tmpk8s4cp1x' Check the logs for full command output.

查了很多,真的不懂如何解决,小白求专业人士帮助!谢谢。
一天也没解决,我就是一个刚下载python的小白 饶了我吧

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • dabocaiqq dabocaiqq 2年前

    pythonv版本不兼容,很常见的问题

    点赞 评论 复制链接分享