2016-11-17 06:25
浏览 54

无法使用Python 3.6.0 a4-amd64安装matplotlib

when downloading a pip using python 3.6, for example,

pip install matplotlib 

using admin cmd prompt.

It keeps giving me error

code 1 "python egg_info" failed in error 1.

I have installed setup tools and have my wheels up-to-date.

What am I doing wrong or what do I need to do to resolve this problem?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • duanpiao6679
    duanpiao6679 2016-12-27 17:03

    There is currently no stable (working) version of matplotlib out there for python 3.6. But there is a release candidat with version number: 2.0.0rc2. You are able to install this version without any problem. Just specify this version on install:

    pip install matplotlib==2.0.0rc2

    If you have installed any other Version or if you want to upgrade lateron use the -I switch of pip like:

    pip install -I matplotlib==2.0.0rc2

    ... to ignore the installed package and reinstall it instead.

    If you try this later, check the newest version and change it, to avoid an error.

    Later on, if matplotlib is stable, the error sould be gone. But for now, this is the only working solution. The Problem in this case is not matplotlib itself, it is caused by the packages "png" and "Freetype".

    点赞 评论
  • dongping2023
    dongping2023 2016-11-17 08:47

    Are you sure you are using pip for python3? try with

    pip3 install matplotlib 
    点赞 评论