doupian9490
2016-10-08 22:12
浏览 86
已采纳

无法在visual studio 2015中安装memcached

I am trying install memcached in visual studio in a PHP project

I am running the following command in the Package Manager Console :

PM> Install-Package EnyimMemcached

I am getting the error "Install failed. Rolling back... "

The full error:

Attempting to gather dependency information for package 'EnyimMemcached.2.16.0' with respect to project ', targeting 'Unsupported,Version=v0.0'

Attempting to resolve dependencies for package 'EnyimMemcached.2.16.0' with DependencyBehavior 'Lowest'

Resolving actions to install package 'EnyimMemcached.2.16.0'

Resolved actions to install package 'EnyimMemcached.2.16.0'

Install failed. Rolling back...

Package 'EnyimMemcached.2.16.0' does not exist in project 'project'

Package 'EnyimMemcached.2.16.0' does not exist in folder 'C: \packages'

Install-Package : Could not install package 'EnyimMemcached 2.16.0'. You are

trying to install this package into a project that targets 'Unsupp orted,Version=v0.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

At line:1 char:16

  • Install-Package <<<< EnyimMemcached

    • CategoryInfo : NotSpecified: (:) [Install-Package], Exception

    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

I have tried different php version to see if the issue is with the version and still getting the same error

图片转代码服务由CSDN问答提供 功能建议

我正在尝试在PHP项目中的visual studio中安装memcached

I 我在包管理器控制台中运行以下命令:

PM&gt; 安装包EnyimMemcached

我收到错误“安装失败。回滚...”

完整错误: \ n

尝试收集程序包'EnyimMemcached.2.16.0'的相关项目'的n依赖项信息,目标为'不支持,版本= v0.0'

尝试 使用 DependencyBehavior'最低'来解析包'EnyimMemcached.2.16.0'的依赖关系

解决安装包'EnyimMemcached.2.16.0'的操作

解决了安装包'EnyimMemcached.2.16.0'的操作

安装失败。 回滚...

项目'project'中不存在包'EnyimMemcached.2.16.0'

包'EnyimMemcached.2.16.0 文件夹'C:\ packages'中不存在

安装包:无法安装软件包'EnyimMemcached 2.16.0'。 您

尝试将此软件包安装到以'Unsupp orted,Version = v0.0', 为目标的项目中,但该软件包不包含任何程序集引用或内容文件 与该框架兼容。 有关详细信息,请与软件包作者联系。

在行:1字符:16

  • Install-Package&lt ;&LT;&LT;&LT; EnyimMemcached

    • CategoryInfo:NotSpecified:(:) [Install-Package],Exception

    • FullyQualifiedErrorId: NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

      我尝试过不同的php版本 看问题是否与版本有关并仍然得到相同的错误

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • duandaodao6951 2016-10-10 07:42
    已采纳

    “EnyimMemcached” need .NET Framework 3.5 or later version to use. Please refer to here for details: https://github.com/enyim/EnyimMemcached. If you install “EnyimMemcached” to any projects which target to previous version of .NET Framework that before 3.5, you will get the same error.

    Since PHP proejct isn’t a .NET Framework type project, you could not install “EnyimMemcached” to a PHP project. If you want to use “memcached” in a PHP project, you need to install and configuration based on below document that from PHP site.

    http://php.net/manual/en/book.memcached.php.

    点赞 评论

相关推荐 更多相似问题