dongxing1965
2014-02-24 20:08
浏览 76
已采纳

使用PHP在AWS EC2实例上运行Apache2网站

I am not exactly sure what is going on here, but I imagine there is a problem with permissions. I will try to describe the symptoms and hopefully someone will have a cure? I am trying to run my website on an EC2 instance. I installed lamp by following this guide: https://gist.github.com/aronwoost/1105007. The website uses php, mysql and javascript. I see that I am able to access the mysql database by running the query from a php file but there are plenty of things that don't work right:

  1. When I use "include 'databaseinfo.php';", it automatically prints the contents of the file instead of importing the variables so I can make more secure mysql queries.
  2. In the main index.html file, I have some php code and try to get it to echo some html to run, but instead the html is just echo'ed as text instead of actually getting run.

EDIT: The only modification I have done to httpd.conf is this section:

<Directory "/var/www/html">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride All
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douhao7677 2014-02-24 20:14
    已采纳

    Sounds like a mimetype issue. You might add this to your .htaccess (or to your main apache conf):

     AddType application/x-httpd-php .php .html
    
    打赏 评论

相关推荐 更多相似问题